Finder wants to make changes - ext HD

Discussion in 'OS X Yosemite (10.10)' started by William8606, Mar 30, 2015.

  1. William8606 macrumors newbie

    Joined:
    Mar 30, 2015
    #1
    I just added time machine to one of my external hard drives. Not sure if this is a factor.

    When I create a new folder or delete a file on this hard drive, I get a message "Finder wants to make changes" and must enter my password.

    The other hard drive works fine. How to fix please.
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    This would be a permissions issue. Open "Get Info" or press Command-I on the drive, then change so you have read/write access under "Sharing and Permissions" (you might have to unlock and type in your password to do this). Also make sure you click on the settings menu and select "Apply to enclosed items" to make sure all files and folders get the change.
     
  3. William8606 thread starter macrumors newbie

    Joined:
    Mar 30, 2015
    #3
    That worked! Thanks. Somehow my username was deleted from the list for that hard drive so I added per your directions.
     
  4. brningwyre macrumors newbie

    Joined:
    Jan 28, 2017
    #4
    Thanks loads, Red. I almost had this figured out, only to be foiled by the Little Black Gear in the lower left corner of every Get Info box.

    brningwyre
     

Share This Page