Finder Won't Open?

Discussion in 'macOS High Sierra (10.13)' started by powerbook911, Oct 6, 2017.

  1. powerbook911 macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #1
    I've had High Sierra installed for a week.

    However, beginning today, finder will not open no matter what I do. I restart the machine, no help. I "relaunch" finder, no help.

    The machine runs flawlessly, but you cannot open finder!

    Any tips? I tried booting into safe mode, but finder doesn't open there either.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    A corrupted "finder prefs" file -might- be the cause of this.

    Try this:

    1. Go into your Preferences folder (in your home folder)
    2. Move to trash any files there with the name "com.apple.finder.plist" (may be more than one)
    3. DO NOT EMPTY TRASH just yet
    4. Reboot
    5. NOW empty the trash

    Does this help at all?
    It may or may not, and won't hurt anything.
     
  3. powerbook911 thread starter macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #3
    Thank you Sir!

    Unfortunately, no folder would open as it would use finder.

    I was pulling my hair out over this even though the rest of the machine was flawless. You couldn't access finder through "save as" in any apps either as that just opens up finder essentially.

    I thought "I wonder if High Sierra has an update and it might force something to be fixed by chance?" Well, there was an update.

    Evidently, the High Sierra update was big enough that it replaced whatever went bad. Fingers crossed it won't happen again as I don't know how you would fix it otherwise! No finder really cripples the machine! ha.
     
  4. tn-xyz macrumors regular

    tn-xyz

    Joined:
    Sep 13, 2017
    #4
    i had a similar issue, although finder worked for me in safe mode.
    i believe it was the indexing that went wrong.
     

Share This Page

3 October 6, 2017