Finder won't run/Hard Drive won't mount on restart!!

Discussion in 'macOS' started by johnny88, Nov 13, 2007.

  1. johnny88 macrumors newbie

    Joined:
    Jun 3, 2006
    #1
    Hey all.

    Restarted my Powerbook G4 on OSX yesterday, and for some reason, the Finder does not run, and the HardDrive icon does not appear. My top bar appears, and my Dock appears with all my programs, but the desktop is empty!?! :eek:

    The programs on the Dock work (hence the internet). but I can't access the Harddrive! Ahhh! There were some files on the desktop and on my HD that I needed, so surprisingly I was able to open up Acrobat, hit open, and locate and open these files, and then save them to a USB drive....but why doesn't my finder work or harddrive mount?? :confused:

    I've zapped the P ram and nothing was fixed, I ran disk utility from my OSX CD...no problems. WTF?? I also read somewhere about a divx problem...but I ran that code in terminal....and nothing was found/fixed.

    Please help....I need my PB for work ASAP!!
    Any suggestions?

    Thanks guys....love the site! :)
     
  2. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
    #2
    Go to Preferences in Finder, and check these are ticked:

    [​IMG]
     
  3. johnny88 thread starter macrumors newbie

    Joined:
    Jun 3, 2006
    #3
    Kilamite....finder won't launch at all...only programs will....so I would be unable to go to preferences in finder...
     
  4. naftalim macrumors 6502

    Joined:
    Sep 18, 2007
    Location:
    Vancouver, BC
    #4
    I am having the same problem on a friends computer, so here is the solution I was given. Use Spotlight to get to Terminal


    -----------------------

    Since the command has sudo at the beginning I suggest logging into an Admin Account as a regular account doesn't have the permissions and privileges needed to execute those commands.

    Next, launch Terminal then type the following exactly as written:


    Code:
    sudo mv /library/Application Support/DivXNetworks to execute this command press enter. You will be asked to enter your Admin Password.

    Next type the following:


    Code:
    sudo mv /library/Application Support/DivXNetworks.prev

    Once again, press enter to execute the command and enter the Admin Password to continue.

    A word of warning. When using sudo, please take care to look at what you've typed and check the letters/spacing before pressing enter.

    Now, on to the Finder Preferences. You'll find them here:

    Macintosh HD ~> Library ~> Preferences ~> com.apple.finder.plist

    Delete this file then log out/back in. New Finder Prefs will be created when you are logged back in.





     
  5. johnny88 thread starter macrumors newbie

    Joined:
    Jun 3, 2006
    #5
    Thanks naf...but I had tried that already....found that solution in the Apple forum...BUT, when I do it I says "no such file or directory". I guess DivX isn't the problem.


    ALSO....I didn't mention...I am running OSX 10.4.10....
     

Share This Page