Finding Mac OS X Tiger for PPC macs

Discussion in 'Mac Basics and Help' started by DK8, Dec 21, 2008.

  1. DK8 macrumors newbie

    Joined:
    Nov 26, 2007
    #1
    I've got a G5 that runs 10.3.9 which is handy for certain applications - but a couple of applications now won't work with anything older than Tiger 10.4.11 - I want to get ahold of Tiger for PPC and install it on an external HD - As it's proving hard to find it except for silly money, might I have more joy buying an external drive with 10.4 on it? I seem to recall the 10.4.11 is the last version available to PPC Macs. Any all advice appreciated
     
  2. PlaceofDis macrumors Core

    Joined:
    Jan 6, 2004
    #2
    Leopard will run on PPC too, but if you don't want to go that route... any retail version of 10.4 would work for you. afaik they never shipped a retail version that was Intel so just fine a retail package of 10.4 on ebay.
     
  3. JustGretchen macrumors 6502

    Joined:
    Dec 2, 2008
    #3
    Just get Leopard it will run just fine on your G5. We have an original single 1.8ghz g5 tower with 3gb of ram and leopard runs great.

    You won't find Tiger at any apple store :)
     
  4. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #4
    Yep. Tiger Retail was never Intel-only (or Intel at all), so any retail disk you find will be PowerPC only.
     
  5. PYR0M310N macrumors 6502a

    PYR0M310N

    Joined:
    Aug 29, 2006
    #5
    I have a PPC G5 with Leopard on it, and it runs really well with it, so I'd go for that if I were you.
     

Share This Page