Finding Time Capsule's HD from PC

Discussion in 'Mac Accessories' started by arbitrage, Mar 19, 2009.

  1. arbitrage macrumors 6502a

    Mar 19, 2009
    Hi, I have a new 500GB TC and my network consists of a Windows XP Desktop ethernet wired to the time capsule and then my 13" Alu Macbook via wireless to the Time Capsule. I am having two problems:

    1. How do I see the TC's internal HD from my PC? I have used AirPort Utility from the PC to set up TC and have turned on file sharing but don't know where to access the drive from. It doesn't show up in Windows Explorer or Network Places etc.

    2.I have a Comstar Platinum USB HD that is connected to the Time Capsule, when I turn the USB HD on it basically causes the TC to crash. The USB HD is partitioned, one half is my old time machine backup for my Macbook (but now I have a new backup on the TIme Capsule's HD) and the other partition is a Windows NTFS drive with Folders/Files backed up via copy/paste from my PC. Is this the wrong drive format for the mac and the PC to share files? Do I need to reformat the drive and if so, what format should the USB HD be in to use it to share files between a PC and a MacBook? OR... is my drive just not compatible with the TC and thats what is causing it to crash???

    Any help would be appreciated.

  2. arbitrage thread starter macrumors 6502a

    Mar 19, 2009
    I've solved my own problem after numerous google searches so I'll post in case anyone else has this problem.

    In order to see my TC from my XP PC I had to go into MyNetworkPlaces and go thorugh adding a new network place...then had to enter: \\"IP address of TC"\"name of time capsule"(which happens to be "Time Capsule") this then opened access to the hard drive through NetworkPlaces in Windows Explorer.

    I was also able to set up the same sort of thing for the connected USB drive with the same \\IPaddress(same one of the TC)\name of drive(this is found in Airport Utility under shared drives)

    However this only gave me access to the old Time Machine area of my USB drive and I still can't find access to the Windows partition even trying the same process as I did with the others.

    So hope this helps someone out there.
  3. phette23 Guest

    Thank You

    I just wanted to thank you for posting your solution. It was one of the top Google hits when I looked for how to fix much the same problem (only difference was other PC was connected via Airport too and not ethernet) and it worked right away.

    My only comment is that your Time Capsule might not be named what you think it is. For me, the ISP apparently took the place of what I thought my Time Capsule was named (and what the name shows up as in Airport Utility); instead, the first and only folder within the Time Capsule itself was what I had to put into the location. So it looked like \\"IP Address"\"[My name]'s Time Capsule" though Time Capsule got truncated to "Time Ca" because I have a rather long last name.

    Once again, thanks.
  4. JFKJr macrumors newbie

    Feb 12, 2012
    Time capsule name

    I was having the same problems but was able to have a PC access the Time Capsule in order to use it for back-ups. I had previously set up the TC using a Mac.

    I used the Add Network location as indicated above, however, the IP address of the Time Capsule was not the address that first showed when I accessed the AirPort Utility on my MAC. Instead I had to enter the manual set up of Airport which, on the Summary Page, revealed the true IP address. Also, the "name" was not the Time Capsule name shown using the Airport Utility. I had to use the Disk name which, in Airport Utility, is shown on the Disk page of the Airport Utility Manual set-up. In my case it was simply "Data". Once I identified the location as \\correct IP address\Data I was prompted to supply the user name and password. Not sure I ever used a user name setting up the TC but I put mine in and the TC password and finally my PC could see the TC harddisk. Backup was then no problem.

Share This Page