Resolved finishing sync

Discussion in 'iPhone Tips, Help and Troubleshooting' started by p3ncil, Oct 23, 2013.

  1. p3ncil, Oct 23, 2013
    Last edited: Oct 29, 2013

    p3ncil macrumors regular

    Jul 6, 2009
    [Marked as Resolved] Probably a bug :(

    Prior to the upgrade to 7.0.3 and Mavericks my iPhone was syncing well with my Mac.

    However after the upgrade, my iPhone is stuck at 'Finishing Sync' forever... I've tried changing libraries for iTunes but to no avail or even restarting both devices to no avail.

    Anyone? Thanks so much!

    Edit : tried restoring my device. successfully synced everything on my first few attempts. Appears that after adding some music into my iPhone the whole finishing sync bug appeared again.
  2. Gary Posselt macrumors newbie

    Oct 25, 2013
    Finishing Sync

    Have exact same problem...downloaded Mavericks yesterday, including updates. Sync stays stuck in "finishing" mode. I eject using lower left gear symbol...and sync stops, everything is fine. Tried syncing again, it worked. Tried syncing after adding photos and the "stuck" problem reappears. Only gets stuck when adding items. Never happened before Mavericks.
  3. tlmurray macrumors newbie

    Jun 17, 2006
    Same here

    I find if I add or delete a song or a photo or update an app, the sync never finishes. After I give up and simply eject the phone, I see that the change was indeed made. If no changes are made and then I plug in the phone, the sync finishes.
  4. Morac macrumors 65816


    Dec 30, 2009
    I see this on my Windows machine as well. From what I've been able to tell, sync actually is finishing as the "Sync" button re-enables and the spinning wheel on my iPad and iPhone disappear. It's just the "Finishing Sync" text never goes away, so it looks like a display issue.
  5. p3ncil thread starter macrumors regular

    Jul 6, 2009
    Yep... the Data is passed onto the device.
    I guess it's a bug with the Finishing Sync.

    Thanks guys!
  6. zeblouze macrumors newbie

    Oct 29, 2013
    synchro fixed

    Hello I had the same issue.
    Iphone 5 7.0.3 and mavericks just installed

    Restoring the phone and reinstall of iTunes wasn't efficient.

    I finally decided to call the Apple support

    First they confirmed that many people experience the same issue
    Second : The supervisor spent a lot of time with and tried to understand. and she finally could work through it and she gave me the solution

    hope it will work for you :

    The path to iTunes Music folder had been modified (maybe during 10.9 installation)
    She told me to point on the Music folder again and rebuild the library....
    And then : OK !

    it synchronises, music is transferred normally


  7. poet1803 macrumors newbie

    Jul 25, 2010
    How to rebuild the iTunes library?

    Hi, Guillaume,

    Your post is interesting, but could you explain in more detail how to rebuild the iTunes library?

    Many thanks,


Share This Page