Firefox 3.6 and special characters

Discussion in 'Mac Apps and Mac App Store' started by iammike1, Jan 24, 2010.

  1. iammike1 macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #1
    Having a strange problem in FF since the update to 3.6. See the attached image.

    I've been getting this with certain special characters, notice the strange boxes.

    Any ideas? Anyone else seeing this? The image is from the front page of MR in the Steve Jobs tablet quote.
     

    Attached Files:

  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    It would be nice is you gave a link to the actual website. As for the special characters, they are apostrophes (’).

    Suggestion: View>Page Source of the problematic webpage. Take note of the character encoding of the page. Make sure that your browser is set to the encoding format of the page. (For example, this page is encoded as Western (ISO-8859-1)). View>Character Encoding>Auto Detect may also do the job.
     
  3. iammike1 thread starter macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #3
    ...and I quote. "The image is from the front page of MR in the Steve Jobs tablet quote."
     
  4. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
  5. iammike1 thread starter macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #5
    Dunno, problem is only in FF 3.6 and I've done a complete wipe of FF, all plist and cache's and still no luck once I reinstall FF.

    I'm not really that worried about it at the moment. It's only certain places.
     
  6. deltaiscain macrumors regular

    Joined:
    Jul 24, 2008
  7. iLina macrumors member

    Joined:
    Dec 15, 2009
    #7
    I got it updated to 3.6 and got the same problem but then i removed the whole browser and installed it again and now it works fine.
     
  8. gibbz macrumors 68030

    Joined:
    May 31, 2007
  9. iLina macrumors member

    Joined:
    Dec 15, 2009
    #9
    Try reinstalling it.
     
  10. gibbz macrumors 68030

    Joined:
    May 31, 2007
    #10
    No luck. Not a big deal for me since I use Safari, but it is interesting that the characters are still messed up.
     
  11. iammike1 thread starter macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #11
    Some of us have done this without success. Maybe share the steps you used to remove and reinstall?

    I removed the application, plist and both cache directories. This reset all settings when I reinstalled FF.

    This did not work for me.
     
  12. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #12
    It's not really a browser issue, but how the news stories get inputted by the staff here. The character encoding gets a little goofy sometimes. This type of issue has been brought up a couple times. It looks like MR deleted the offending apostrophes now though, but now there's grammatical errors as a result :)

    Example:
    http://forums.macrumors.com/showthread.php?t=93058&highlight=character+encoding
     
  13. iammike1 thread starter macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #13
    Guess it just kinda sucks that this problem only effects FF 3.6 in this case. Safari and Chrome were able to display the same article without issue.

    I'll probably end up back on Safari anyway after the newness of 3.6 wears off.
     
  14. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #14
    A quote is not a link. Who is going to help you if they have to do a Google search to find the problem?
     
  15. iammike1 thread starter macrumors 6502a

    iammike1

    Joined:
    Oct 25, 2007
    Location:
    Columbia MD
    #15
    You have to do a google search to go to the main page of the website you are already on? Didn't know it was so complicated.

    Ok, the link is http://www.macrumors.com lol
     

Share This Page