Firefox 3 and rainbow spinning pinwheel

Discussion in 'Mac Apps and Mac App Store' started by brand, Jul 4, 2008.

  1. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #1
    Ever since upgrading to Firefox 3 on both my Mac Pro and my Mac Book Pro I am repeatedly getting a rainbow spinning pinwheel. Firefox will work for 2-5 minutes and then I get the rainbow spinning pinwheel for about a minute then Firefox will work for 2-5 minutes then the spinning wheel again. This is how its been since I upgraded to Firefox 3. I never had this problem with Firefox 2. This is very frustrating because Firefox is my preferred browser.

    The extensions I have installed are:
    AdBlock Plus
    ColorfulTabs
    CustomizeGoogle
    Foxmarks Bookmark Synchronizer
    Tab Mix Plus
    PDF Download
    TagSifter
    1Password

    I have repaired disk permissions.

    Any ideas?
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    Update from fx2 to fx 3 might sometimes (but rarely) corrupt some files in your profile. try a new profile and see if problem persist.

    You can backup your library from bookmark manager and export/import passwords with addon "password exporter"
     
  3. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #3
    use a more stable web browser. Firefox 3 will get better with each point release, but most have found that the Mac version was definitely not ready to come out of beta.
     
  4. bobber205 macrumors 68020

    bobber205

    Joined:
    Nov 15, 2005
    Location:
    Oregon
    #4
    I think this is a profile issue. I've been using Firefox 3 since the first Beta and it has yet to crash...
     
  5. JubileeC macrumors newbie

    Joined:
    Jul 22, 2007
    Location:
    Edinburgh
    #5
    Hmm

    Actually, I had been using the Firefox 3 browser since the last but one beta and it had been working fine until about 4 days ago, since when it has been giving me similar spinning rainbow circles. I changed profiles, even uninstalled it completely (including removing all profile information) and then reinstalled it but it remains stubbornly in "hang" mode. I'm using a new iMac 2.4GHz with 1Gb.

    I also have a 2.16GHz Macbook with 2Gb and it has no problems at all with Firefox. So I can only assume it is a memory issue. But, I am afraid to say, having been a Firefox user since it first came out, I am now reluctantly going to have to stop using it.
     
  6. pnosko macrumors newbie

    Joined:
    Apr 30, 2008
    #6
    The only problem I have with Firefox 3 is being unable to download attachments, which is a big issue. I get the spinning wheel and have to force quit Firefox. I've got a Mac Pro w/16gb, so memory can't be the issue.
     
  7. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #7
    see my #2 post above.
     
  8. Father Jack macrumors 68020

    Father Jack

    Joined:
    Jan 1, 2007
    Location:
    Ireland
    #8
    I downloaded FF3 the day it became available. After three days and three system freezes I dumped it and reinstalled version 2 ... it has been running perfectly since .. :)
     
  9. MagnusVonMagnum macrumors 601

    MagnusVonMagnum

    Joined:
    Jun 18, 2007
    #9
    I have no idea how you came to that assessment with the word 'most' there. I haven't seen that many complaints. Firefox3 works like a charm here 99% of the time in both Tiger and Leopard on my upgraded 1.8GHz 7448 G4 PowerMac. I wouldn't call it 'unstable' and wipes the floor with Safari 3.1, in my opinion. So, no thanks. I'll stick with Firefox3.

    I'd imagine the person's problems are related to either an unstable add-on or somehow something in his configuration has become corrupted.
     
  10. pnosko macrumors newbie

    Joined:
    Apr 30, 2008
    #10
    Thanks. I believe I found the problem. I apparently last saved to a networked drive that was unavailable (I only use my Dell when I have to and keep it powered off), and it was a "network hang."
     
  11. flignar macrumors newbie

    Joined:
    Jul 10, 2009
    #11
    Performance Fixed...spinning has just plain stopped.

    I turned off my last two add-ons... Google Toolbar and Web Developer and the spinning has just plain stopped.
     

Share This Page