Firefox 3: Bookmarks Toolbar not working properly?

Discussion in 'Mac Apps and Mac App Store' started by pusman83, May 17, 2008.

  1. pusman83 macrumors regular

    Joined:
    May 9, 2005
    #1
    I updated to FF3 and it seems my Bookmarks Toolbar wasn't "imported" properly with the rest of my preferences.

    Currently, I have a blank Bookmarks Toolbar (and I can't drag anything to it!!), and a Bookmarks Toolbar folder in the Bookmarks menu with all my previous Bookmarks Toolbar bookmarks.

    Anyone know what the issue is?
     
  2. pusman83 thread starter macrumors regular

    Joined:
    May 9, 2005
    #2
    Hmmm, it looks like my FF2 items were actually being displayed in the "Google Toolbar", but that still doesn't explain why I can't add anything to the BT.
     
  3. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #3
    try re-open Fx2, and export bookmark to bookmarks.html file, and then open firefox 3, and import it.
     
  4. macaroo macrumors newbie

    Joined:
    Mar 6, 2008
    #4
    Error installing Google Toolbar in Firefox 3 for Mac

    This is the error I get when installing Google's Toolbar on FF3 on my Mac:

    Error
    Firefox could not install the file at

    http://dl.google.com/firefox/google-toolbar-ff3-mac.xpi

    because: Unexpected installation error
    Review the Error Console log for more details.
    -203

    Is this the case for everyone else?
    If so, hopefully Mozilla will address this issue...
     
  5. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
  6. Ben Kei macrumors regular

    Joined:
    Oct 30, 2002
    Location:
    London UK
    #6
    I'm getting the same problem:

    http://forums.macrumors.com/showthread.php?t=502818

    I'm also getting a couple extra too.
    My navigation bar isn't showing URLS unless I click on the favicon to the Left.

    All new windows are opening up blank, full screen and even clicking the Home button doesn't take me to home (but occasionally takes me to the firefox Google start page)

    Typing URL's directly into the navigation bar and hitting enter does nothing at all.

    All preferences, cache files, profiles etc... have been deleted and I've re-downloaded the DMG to reinstall from and still the same problems.
     
  7. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #7
    new profile as this doesn't help at all?
     
  8. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #8
    I get a similar problem when trying to install any add-ons in the new FF3.

    No matter if I go to the add-ons webpage or the Get Add-ons window in FF3, I get this message when I try to download an add-on:

    _Skjermbilde 4.jpg

    The problem actually started with one of the last FF3 release candidates, and it doesn't matter if I start FF3 by double-clicking the application or use LaunchBar to launch it...

    I've deleted the old profile, re-downloaded/-installed FF3 and deleted the preference file. Twice.

    The real kick in the nuts is that if I go to the add-ons webpage with Camino and download the xpi files I can get FF3 to install them by using File -> open. :confused:
     
  9. kleinebre macrumors newbie

    Joined:
    Jun 19, 2008
    #9
    Something went wrong importing the bookmarks. I had the same problem on my Ubuntu machine. This is what I did to solve it:
    - Shut down firefox
    - Opened the hidden folder .mozille/firefox-3.0/smbkmpt4.default
    (this is where the user settings are stored, the last folder name may differ)
    - renamed places.sqlite to places.sqlite.old (this is where the new firefox stores bookmarks
    - in folder .mozille/firefox-3.0/smbkmpt4.default/bookmarkbackups/ I deleted the .json bookmark file.
    - After restarting firefox, firefox thought it had not imported the old firefox 2 html bookmarks yet, so it tried again. My bookmarks then appeared on the bookmarks toolbar folder.

    Hope this helps someone,
    Marc
     
  10. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #10
    Seems the download errors have cleared up today (for the most part).

    I am again able to get the add-ons I want (except for the British and Norwegian dictionaries which for some odd reason won't work :().
     
  11. chjr7777 macrumors newbie

    Joined:
    Mar 1, 2008
    #11
    Finally got the Google Toolbar to install

    I think the problem is with Fast User Switching & Firefox 3.
    My wife has her own logon to our iMac & so do I.
    The toolbar installed no problem for me, but I kept getting the "Firefox could not install the file at " error.

    So based on the instructions below I created another Firefox profile for her & it installed without any problems.

    Logged on as the user having problems, here is what I did:

    http://support.mozilla.com/en-US/kb/Managing+profiles

    Mac OS:
    1. Exit Firefox. To close Firefox, in the menu bar, select the Firefox menu, and then select Quit Firefox.
    2. Navigate to /Applications/Utilities. Open the Terminal application.
    3. In the Terminal application, enter the following:
/Applications/Firefox.app/Contents/MacOS/firefox -ProfileManager

    http://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile

    To start the Create Profile Wizard, click Create Profile... in the Profile Manager.
    Click Next and enter the name of the profile. Use a profile name that is descriptive, such as your personal name. This name is not exposed on the Internet.
    You can also choose where to store the profile, which is useful if you plan on exporting your data and settings to another computer or setup in the future. To choose its storage location on your system, click Choose Folder....
    Note: If you choose a custom location for the profile, store it in a new or clean folder. When you choose to remove the profile, all contents stored in the same folder are removed.
    To create the new profile, click Finish.
    The new profile is displayed in the Profile Manager.

    Open Firefox.

    Install Google toolbar
    http://www.google.com/support/firefox/bin/answer.py?hl=en&answer=22027
     

Share This Page