Firefox 3 opens in safe mode with Quicksilver?

Discussion in 'Mac Apps and Mac App Store' started by dcnicholls, Jun 19, 2008.

  1. dcnicholls macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #1
    I set Quicksilver to open FF (2.0.x) months back using a keyboard shortcut (option-command-F) and it has worked well on my iMac (10.5.3).

    However, I installed FF3.0 over top of it yesterday and, while the program worked well and I could run it from the Dock as normal, the Quicksilver keyboard shortcut triggered the "opening in safe mode" window every time.

    So I downgraded to FF2.0.0.14 and the Quicksilver shortcut ("trigger") is working as before.

    Does anyone have an idea why FF3 should behave like this? And how to fix it?

    DN
     
  2. pjrobertson macrumors 6502a

    Joined:
    Nov 14, 2007
    #2
    Try deleting your trigger in the QS preferences and starting again. That's probably where your problem is.
     
  3. dcnicholls thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #3
    Yes, that was the first thing I tried. It didn't work.

    Paradoxically, (on two occasions I tried it) when I launched FF3 using Quicksilver shortcut, the first time after a boot, it worked, but closing FF (command-Q) and trying it again caused the problem. Weird.

    If FF was running with no window or minimized, the problem didn't occur and QS opened the FF window as normal.

    DN
     
  4. siren77 macrumors member

    Joined:
    Oct 11, 2007
    #4
    Yeah I'm having the exact same problem. Only the trigger creates this problem, invoking FF3 from a quicksilver search works normally.
     
  5. pjrobertson macrumors 6502a

    Joined:
    Nov 14, 2007
    #5
    I've just tried it and I'm getting the same bug. I've put it on Blacktree's bug tracker.
    There might be a fix soon as there's a developer (tiennou) who's currently making a bug-fix release.
     
  6. dcnicholls thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #6
    I just had a reply on another forum I posted this to, which suggested that it is the Option key that is causing the problem, and that a short press of a Quicksilver keyboard shortcut will avoid the problem - I have not tested this as I don't currently have FF3 installed.

    I'd be interested to know if the suggested fix works: see the post by Xentric at http://forums.mozillazine.org/viewtopic.php?f=9&t=674355&p=3596605#p3596605

    DN
     
  7. pjrobertson macrumors 6502a

    Joined:
    Nov 14, 2007
    #7
    It still doesn't work for me but if you change your hotkey so that OPTN isn't part of it then it does work :)
     
  8. dcnicholls thread starter macrumors newbie

    Joined:
    Dec 13, 2007
    Location:
    Canberra, Australia
    #8
    Aha! Thanks. Looks like the change to using the Option key to open FF3 in safe mode is what has triggered the bug. So control-command-F should work.

    DN
     

Share This Page