Firefox 3 refuses to load images properly

Discussion in 'Mac Apps and Mac App Store' started by Pat H, Mar 8, 2009.

  1. Pat H macrumors member

    Joined:
    Jan 14, 2008
    Location:
    New Jersey, USA
    #1
    Firefox (3.0.7, latest version) for OSX has been a nightmare lately. I prefer it to Safari because of the extensions, but I'm thinking of ditching it. Some web pages seem to be fine, but most will only load about half of the images.

    For example, on Facebook I'll get about half of the profile pictures to load on my friends list, and the others will just display a broken image link icon. The same occurs with forums (people's avatars), and even with some major websites, where there will just be huge gaps in a page where the images are supposed to be. I've checked the auto load settings and I don't have any exceptions, so every site should be allowed to load images immediately without permissions.

    What's going on here? Safari is loading most images fine.
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Well since you mentioned extensions, do you believe any of those are interfering? I occasionally run into that with my AdBlock and NoScript add-ons. Also, do you have any links so we can see if it's just your Firefox. Lastly, try viewing the pages while running Firefox in safe mode to see if it persist.
     
  3. jeremybuff macrumors regular

    Joined:
    Mar 3, 2009
    Location:
    Asheville, NC
    #3
    About:Config

    If you have messed with the pipelining settings in the about:config menu, then reset them to their defaults.
     

Share This Page