Firefox - Always saves file to Desktop on "opening" (not saving) a file

Discussion in 'macOS' started by Karvel, Nov 2, 2007.

  1. Karvel macrumors regular

    Joined:
    Jun 27, 2007
    Location:
    England
    #1
    Hello,

    In Firefox on Tiger, when one decides to simply open a file (instead of saving it), this file gets saved to the desktop. It seems to me that it should instead be saving the file to some kind of temporary folder somewhere, or at least a folder which I myself can specify.

    Is there any way to specify where the file gets saved for "opening" - and does Firefox in Leopard behave differently with regard to this? (Not sure why it would but worth enquiring anyway!)
     
  2. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #2
    I've noticed that Firefox on Leopard stores it's temp downloads (like PDFs that you open) in the Downloads folder in your home directory, where as in Tiger it was on the Desktop.

    This isn't an option in Firefox....so it must be a setting in Leopard. Maybe it's controlled by a setting in Safari?

    -Kevin
     
  3. Karvel thread starter macrumors regular

    Joined:
    Jun 27, 2007
    Location:
    England
    #3
    Cheers. Still not as good as having them saved somewhere where I will never see them (I am simply opening the files, not saving them), but an improvement nevertheless. :)

    None of my save settings in Safari ("Save downloaded files to:", "Save Page As...", "Download Linked File As..." and "Save Image As...") point to the Desktop as far as I know.
     
  4. thawn macrumors newbie

    Joined:
    Jan 15, 2008
    #4
    Same problem here

    Hi I have the same problem (OS X 10.4.11 firefox 2.0.0.8)
    I read in another forum, that it should be possible to change this behavior in safari, but that did not work for me.

    Does anybody have any solutions for this?

    I find it really annoying having to clean up my desktop every few days, because firefox decides to pollute it without giving me the option to change that behavior!

    It is probably some mac os temp file setting buried deep in the system.

    Any help would be greatly apreciated!
     
  5. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #5
    Tiger is using desktop as temp folders, so its not firefox's fault

    there was a way to change temp folder locations through safari, which will solve your problem with firefox. but recent update of safari from apple (to 3.0.4) killed that solution..

    there is no way around this for now, unless you downgrade safari to 2.0.4

    go report a complain to apple maybe.
    http://forums.mozillazine.org/viewtopic.php?t=552309&start=0&postdays=0&postorder=asc&highlight=
     
  6. hierobryan macrumors 6502a

    Joined:
    Jan 4, 2008
    Location:
    earth/jupiter
    #6
    Replying to subscribing to the threading.:apple:clicks Submit Reply:apple:
     
  7. thawn macrumors newbie

    Joined:
    Jan 15, 2008
  8. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #8
  9. eyespy macrumors newbie

    Joined:
    Mar 9, 2008
    #9
    Firefox - Always saves file to Desktop on "opening" (not saving) a file

    It must have something to do with the "new" versions of Firefox as when I first install Firefox with say version "Firefox_Setup_2.0.0.7.exe" it will give you the option to either open or save, as soon as it does an update, and I am presently at version 2.0.0.12 things change which is a real nuisance. If Firefox doesn't do something soon I will have to abandon it.:mad:
     

Share This Page