Firefox and Mac becoming unresponsive lately

Discussion in 'MacBook Pro' started by nStyle, Dec 8, 2010.

  1. nStyle macrumors 65816

    Dec 6, 2009
    What is the best way to clean up a system that is getting over a year old and has had a lot of files created/installed/deleted in that course of time? I have pretty much 90% of my hard drive filled and that would be a much higher number if you counted the space that spilled over onto the external. Point is I have a lot of spread out files and need everything to come together and work smoothly.

    Of course on a PC I would simply defrag. What do you do on a Mac when it gets slow?

    Also... Firefox has been pissing me off lately. It will stop intermittently every 5-10 seconds for about 2-5 seconds and the rainbow wheel will appear. This is getting annoying. This is my main problem.

    Any suggestions?
  2. tjb1 macrumors 68000

    Aug 26, 2010
    Pennsylvania, USA
    First off, move to Chrome.

    Second, the easiest way to fix all this would be to gather all yours files and reinstall the OS.
  3. Stvwndr219 macrumors 6502

    Jan 26, 2009
    maybe try the verify/repair disk permissions and disk in disk utility?
  4. jenzjen macrumors 68000

    Aug 20, 2010
    +1 ... I usually nuke my machines once/year, and they always come back much better. Gets rid of lots of random stuff that you don't occur is happening, apps you no longer need, etc.
  5. chico253 macrumors newbie

    Jun 13, 2011
    This has been becoming a very big problem, I see posts everywhere about this issue. I have been trying to find a solution with no luck so far. Please let me know if you have found a remedy. I did a rebuild of my Firefox profile yesterday and that did not help. I am always blaming my mac for poor performance and do the verify disk and rebuild permissions chore but the problems always come back to firefox. Firefox locks up, becomes unresponsive, beachball always spinning when I am trying to browse. when I Force shutdown and reload it will run fine again for a short period.
  6. AMacbook macrumors member

    Jun 13, 2011
  7. jive turkey macrumors 6502

    Mar 15, 2008
    Regarding Firefox problems, if you are using 4.0, go into sync preferences and uncheck the "sync my tabs" option. That fixed these issues that you describe on my machines. .

Share This Page