Firefox and powerbook trackpad sidescroll

wkw

macrumors 6502
Original poster
Mar 23, 2004
289
8
Eugene, OR
Howdy, I have a new Powerbook 17. I am just testing out the trackpad scroll feature and I notice that it behaves differently with Firefox. When I move from side to side the pages go back and forth (like I am clicking the back or forward button) instead of staying in the same page and scrolling side to side. anyone else notice this? I am not sure how to change it, I looked in Firefox preferences but couldn't find anything.

thanks

bill
 

qzak

macrumors 6502
Jan 19, 2005
251
0
yup.. i just got my 17" PB in yesterday, noticed the same thing yesterday while testing it out. i didn't try it in safari cause, well this is my first mac and i gotta say Safari is slow as heck!!! amazing how using one browser is more than twice as fast as using the built in one.
 
Comment

panphage

macrumors 6502
Jul 1, 2003
496
0
It happens to me and it's real annoying. I don't think firefox has any support for mouse gestures and I think that's what the OS is using to get the scrolling effect. If there was someway to remap whatever the scrollpad is sending to firefox I think that'd be the only way.

EDIT: No, safari behaves as advertised, two-finger dragging (I wish I hadn't typed that...) scrolls horizontally.

Also, I just turned off horizontal scrolling in the keyboard/mouse system preferences trackpad tab and the problem goes away. Too bad it also disables horizontal scrolling.
 
Comment

panphage

macrumors 6502
Jul 1, 2003
496
0
ah, nice! Of course, now two finger dragging sideways scrolls vertically...but it's better.
 
Comment

Westside guy

macrumors 603
Oct 15, 2003
5,520
2,476
The soggy side of the Pacific NW
panphage said:
ah, nice! Of course, now two finger dragging sideways scrolls vertically...but it's better.
It should scroll horizontally.

I think the instructions that were pointed to (the iscroll2 page) are incorrect. The ones I followed from the macosxhints site say to set the sysnumlines boolean to true, and that worked for me while the iscroll2 instructions did not.

However all of us with pre-2005 'books should give a big shout-out to Daniel Becker for giving us the ability to scroll with the trackpad! It is SUCH a great feature, and works so much better for me than Sidetrack.
 
Comment

Mechcozmo

macrumors 603
Jul 17, 2004
5,215
2
Westside guy said:
However all of us with pre-2005 'books should give a big shout-out to Daniel Becker for giving us the ability to scroll with the trackpad! It is SUCH a great feature, and works so much better for me than Sidetrack.

I agree, I use it so much... Don't know how I lived without it.

And it impresses the hell out of Windows-using buddies. Another bonus point. :D
 
Comment

panphage

macrumors 6502
Jul 1, 2003
496
0
Westside guy said:
It should scroll horizontally.

I think the instructions that were pointed to (the iscroll2 page) are incorrect. The ones I followed from the macosxhints site say to set the sysnumlines boolean to true, and that worked for me while the iscroll2 instructions did not.

However all of us with pre-2005 'books should give a big shout-out to Daniel Becker for giving us the ability to scroll with the trackpad! It is SUCH a great feature, and works so much better for me than Sidetrack.
Yes, it *should* scroll horizontally, and I know the trackpad is sending different events because before following the instructions horizontal dragging was doing forward-back in history in firefox. After following the instructions (either the iscroll or the macosxhints) horizontal dragging scrolls vertically, just like vertical scrolling. So either it can't be done with the new powerbooks or some further hacking is in order.
 
Comment

eroda

macrumors member
Mar 13, 2005
56
0
well mayby firefox needs an update to suport 2 finger scrolling on imacs!
 
Comment

therevolution

macrumors 6502
May 12, 2003
468
0
In Firefox, type "about:config" in the address bar. Look for these fields and change them to these values:

mousewheel.horizscroll.withnokey.action to 0
mousewheel.horizscroll.withnokey.numlines to 1
 
Comment

panphage

macrumors 6502
Jul 1, 2003
496
0
therevolution said:
In Firefox, type "about:config" in the address bar. Look for these fields and change them to these values:

mousewheel.horizscroll.withnokey.action to 0
mousewheel.horizscroll.withnokey.numlines to 1
Yes, on my new 15" this results in perfect vertical scrolling no matter what. :confused:
 
Comment

therevolution

macrumors 6502
May 12, 2003
468
0
panphage said:
Yes, on my new 15" this results in perfect vertical scrolling no matter what. :confused:
Vertical? It should be scrolling horizontally now.

Are you still using iScroll? Disable it... you don't need it on a new PowerBook.

edit: oh, I see. iScroll's page also has that solution. Well, doing just those two steps solved the problem on my PowerBook. Not sure why yours is doing vertical instead of horizontal.
 
Comment

panphage

macrumors 6502
Jul 1, 2003
496
0
therevolution said:
Vertical? It should be scrolling horizontally now.

Are you still using iScroll? Disable it... you don't need it on a new PowerBook.

edit: oh, I see. iScroll's page also has that solution. Well, doing just those two steps solved the problem on my PowerBook. Not sure why yours is doing vertical instead of horizontal.
Hah, your comment about third party software got me thinking. Now, we know, if anyone else has this problem, I solved it by disabling the SmoothWheel extension. Of course now I've got to deal with the funky jumpy scrolling of firefox but maybe there's another way to fix that.

EDIT: And fixed firefox's painful default scrolling in about:config like this:
mousewheel.withnokey.numlines = 3
mousewheel.withnokey.sysnumlines = false
 
Comment

bousozoku

Moderator emeritus
Jun 25, 2002
13,979
3
Gone but not forgotten.
therevolution said:
Vertical? It should be scrolling horizontally now.

Are you still using iScroll? Disable it... you don't need it on a new PowerBook.

edit: oh, I see. iScroll's page also has that solution. Well, doing just those two steps solved the problem on my PowerBook. Not sure why yours is doing vertical instead of horizontal.
It does the vertical scrolling thing for me too. It's quite interesting.
 
Comment

Converted2Truth

macrumors 6502a
Feb 6, 2004
608
0
Hell@HighAltitude
therevolution said:
In Firefox, type "about:config" in the address bar. Look for these fields and change them to these values:

mousewheel.horizscroll.withnokey.action to 0
mousewheel.horizscroll.withnokey.numlines to 1
You are a godsend. Thanks a bunch!
 
Comment

chamberlain

macrumors newbie
May 4, 2003
10
0
Portland
try…

change those values to 0 and 2 and the the two finger scrolling will work horizontally. if you play around with these numbers you can make the trackpad do other things like change text size. i don't know why but…

Code:
mousewheel.horizscroll.withnokey.action - 0 
mousewheel.horizscroll.withnokey.numlines - 2
 
Comment

Similar threads

Replies
0
Views
186
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.