Firefox and smooth scrolling.

Discussion in 'Mac Apps and Mac App Store' started by Stu L Tissimus, Oct 27, 2007.

  1. Stu L Tissimus macrumors newbie

    Joined:
    Oct 10, 2007
    #1
    I sincerely have no idea how to describe this, but... FF users, is it just me or does smooth scrolling feel laggy? Especially when compared to Safari, which has this really nice preciseness to it when you're scrolling with the Macbook Pro trackpad. Does anybody know how to reduce the lag? Or if it's just an inherent Firefox flaw, is it fixed in the Firefox 3 alphas?
     
  2. foobarbaz macrumors 6502

    Joined:
    Nov 29, 2007
    #2
    This post is a bit old, but I'll reply anyway.

    The so-called smooth scrolling of Firefox isn't as smooth as Safari, because Firefox thinks of scrolling in steps. That's because most non-Mac mice have that sort of mouse wheel. (You know, they click with every "step".) "Smooth scrolling" in Firefox just means taking 1/3 second for each step.

    Check out this bug. It might be changed at some point. Until then, disabling smooth scroll makes it fast...
     
  3. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #3
    Yeah I've noticed this too..in Safari with trackpad scrolling it feels like you're actually moving the page with your fingers...but in Firefox it's more like you're moving your fingers along the trackpad and 2 sec. later it decides to scroll.
     
  4. Ilomoga macrumors member

    Joined:
    Oct 29, 2007
    #4
    Yeah ... but the real horror is using the trackbar to scroll in Windows :(
     
  5. Mac OS X Ocelot macrumors 6502a

    Mac OS X Ocelot

    Joined:
    Sep 7, 2005
    #5
    Smooth scrolling in anything on my mac feels sluggish, especially Finder. Regular scrolling does too, but not as bad.
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #6
    well, get a mice, I do find mice to be more effective in most situations.
     
  7. Ilomoga macrumors member

    Joined:
    Oct 29, 2007
    #7
    Who said I'm not using a mouse? I just complained about the trackbar behaviour in windows not that that's a reason I can't use it ;)

    Btw - it's a notebook and sometimes it just seems unnecessary to put out the mouse, especially with this great touchpad the MacBook has (with its scrolling).
     
  8. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #8
    well, every piece of drivers of your mac is offered by apple.
     
  9. thestaton macrumors 6502

    Joined:
    Jan 19, 2006
    #9
    I thought I was the only one who found it odd. For now I have it disabled it just feels to weird.
     
  10. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007
    #10
    It's not you. Smooth scrolling is laggyin FF. I just turned it off. It doesn't bother me.
     
  11. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #11
  12. Stu L Tissimus thread starter macrumors newbie

    Joined:
    Oct 10, 2007
    #12
    Wow, people actually responded! And the nightly has pixel scrolling! :D
     
  13. pushka macrumors newbie

    pushka

    Joined:
    Jun 24, 2009
    #13
    minefield is the best ^__^

    thank you for the tip ~ good bye safari~~~~

    ---

    also - if you get minefield, you cant install most add ons because they are too old for MF, but you can get an add on to force install them, and they mostly work 100% ~

    http://www.oxymoronical.com/web/firefox/nightly
     
  14. Michaelgtrusa macrumors 604

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
    #14



    How to delete this please?! It's telling me an unexpected error has a occurred!

    I'm thinking that this was a link to a site but it has installed something and will not allow me to delete it!
     
  15. teszeract macrumors newbie

    Joined:
    Dec 14, 2009
    #15
    Firefox Scrolling fixed for me

    All I did was uninstall/disable All in one Sidebar - AIOS.
     

Share This Page