Firefox crashes 100% of the time my late '16 MBP wakes from sleep

Discussion in 'MacBook Pro' started by blSwagger, Dec 25, 2016.

?

Does Firefox crash when waking from sleep on your late 2016 MBP?

  1. Yes, 100% of the time!

    7 vote(s)
    63.6%
  2. Sometimes

    2 vote(s)
    18.2%
  3. Rarely

    0 vote(s)
    0.0%
  4. Never!

    2 vote(s)
    18.2%
  1. blSwagger macrumors member

    Joined:
    Oct 15, 2008
    #1
    I'm a little annoyed that every time I wake my MBP (2.7/460/1tb) from sleep, I find that Firefox crashed. It happens 100% of the time. Sometimes I can't even submit a crash report because that had crashed as well. This was Mozilla's response to me: "hi, this may be a crash apparently related to new mac hardware. this has no fix yet, but is currently actively investigated by mozilla engineers in bug 1320048 - so you might want to follow along there as well..."

    I wanted to switch over to Safari, but I couldn't deal with the lack of favicons. I've tried Chrome, but I prefer Firefox.

    Does everyone else have this problem?
     
  2. __david__ macrumors newbie

    Joined:
    Jan 1, 2017
    #2
    Yes, yes, 100% yes. It's getting really old, too. My Late 2016 15" MBP has all same configuration as my old laptop (I copied my whole home folder over to the new one). Firefox never crashed like this on the old computer.

    Thunderbird is in the same boat. Actually I think Thunderbird is worse than Firefox. Thunderbird crashes nearly 100% of the time, while Firefox seems to crash only 75% of the time. Between the two of them at least one has crashed when I wake my computer up, and quite often the Mozilla Crash Reporter has also crashed, just for good measure.

    It's kind of weird that new hardware is causing an app to crash like this. I suppose some API somewhere is returning something that Firefox/Thunderbird/Gecko doesn't expect.
     
  3. pgc17 macrumors newbie

    Joined:
    Jan 2, 2017
    #3
    I'm having the same problem, with the exact same hardware configuration.. in the above listed bug report, one of the forum posts said that apple had fixed the issue in
    10.12.3 Beta 2 (16D17a), so it looks like we will have to put up with it until 10.12.3 is released.
     
  4. ron1004 macrumors 6502

    ron1004

    Joined:
    Feb 6, 2010
    Location:
    Louisville, KY
    #4
    The latest two FF revisions crash 20 or more times a day on my 2011 MBP, which led to me looking into other browsers.
     
  5. thesaint024 macrumors 65816

    thesaint024

    Joined:
    Nov 14, 2016
    Location:
    suspension waiting room
    #5
    Is this a 15" dGPU problem? I haven't noticed this on my 13" tb. I also don't use Firefox most of the time. I will keep an eye on it going forward.
     
  6. jun180 macrumors regular

    jun180

    Joined:
    Apr 27, 2010
  7. AppleSmack macrumors regular

    Joined:
    Jun 30, 2010
    #7
    There are 6 comments before this one in this thread… does this mean that there are many more Firefox users out there, with the same configuration as OP, *without* these sleep/wake issues?
     
  8. blSwagger thread starter macrumors member

    Joined:
    Oct 15, 2008
    #8
    That's what I'm wondering... whether it's a widespread issue with Firefox on the new MBPs or if Firefox is not being used widespread.
     
  9. AppleSmack macrumors regular

    Joined:
    Jun 30, 2010
    #9
    What I was hoping for was a bunch of Firefox users with the same hardware config to pipe up in here "hey, no problems with my Firefox!"

    Otherwise, I suspect the few people with this problem must have a particular Firefox config (plugins and preferences) that doesn't play well with the new hardware.
     
  10. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #10
    Check out the comment section at the bug report linked in your OP. There's been some success reported of being able to avoid the crash by disabling Fx's relationship with the Mac's tb. One user did report success then failure. It appears it could be an SDK version issue.

    The explanation in external links and the Terminal command to disable starts here (comment #38): https://bugzilla.mozilla.org/show_bug.cgi?id=1320048#c38
     
  11. gtgrad95 macrumors 6502

    Joined:
    May 15, 2007
    Location:
    Atlanta, GA.
    #11
    I am having the same issue. Crashes everytime the MBP comes out of sleep.
     
  12. Wildkraut macrumors 6502a

    Wildkraut

    Joined:
    Nov 8, 2015
    Location:
    Germany
    #12
    Firefox crashes often everywhere, even on Windows.
     
  13. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #13
    Maybe it has to do with your circumstances. I've used Fx for years in multiple OSes and it's never crashed.
     
  14. caddison macrumors member

    caddison

    Joined:
    Mar 9, 2015
    Location:
    Midwest
    #14
    Everyone's circumstances, etc, are different, but I used to be a diehard FireFox guy and eventually had to dump it because of constant issues I had working with Windows.

    I use Chrome now on both Win and Mac when it comes to a third-party browser, but I tend to try to stick with browsers that are native to the OS whenever possible.

    Differences between browsers used to be pretty dramatic, but I don't find that to be the case so much anymore, and native browsers always just seem to behave better.

    Not saying you should switch to something else if you love FF, and it sucks you're dealing with issues... just offering my opinion.
     
  15. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #15
    We should stick to the OP's issue and not get sidetracked, sorry for my part in that. Someone can start a new, favorite browser or how to, thread.
     
  16. LaFrentz, Jan 8, 2017
    Last edited: Jan 8, 2017

    LaFrentz macrumors member

    LaFrentz

    Joined:
    May 13, 2012
    #16
    Glad I found this thread. Firefox running on my late 2016 MBP 15" 2.6/460/512 is crashing about 75% when waking from sleep. For some reasons I had to install Thunderbird as additional mail client which crashes even more often when waking from sleep. No other software shows this behaviour. I have also not experienced any graphic issues so far. Hope Mozilla gets this sorted out soon. It's really annoying.
     
  17. curmudgeonette macrumors 6502

    Joined:
    Jan 28, 2016
    Location:
    California
    #17
    This is an Apple bug, deep in Apple's code.

    The reason that Mozilla products are affected is that Mozilla intentionally fills unused memory with values that cause crashes. This helps find bugs involving stray memory references. In this case, it's found an Apple bug. Apparently, Apple's testing department doesn't test with Mozilla software...
     
  18. bartvk, Jan 8, 2017
    Last edited: Jan 9, 2017

    bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #18
    Edit:
    The solution below is totally overkill. There's a terminal command to avoid this, see message above.
    https://bugzilla.mozilla.org/show_bug.cgi?id=1320048#c38

    --- Old message ---
    To remedy this situation, I've created a Hammerspoon script to kill Firefox when the system goes to sleep, and start it upon waking. In Firefox Preferences -> General, you can configure a setting called "When Firefox starts". Set this to "Show my windows and tabs from last time". Then install Hammerspoon, create the folder .hammerspoon in your home directory and create the file init.lua in that new folder. Then paste the following code in the init.lua file and in Hammerspoon, reload the configuration.

    Code:
        local log = hs.logger.new('mywatcher','debug')
    
        function callback(eventType)
            if (eventType == hs.caffeinate.watcher.systemWillSleep) then
                local firefox = hs.application.find('Firefox')
                if not (firefox == nil) then
                    firefox:kill()
                end
            elseif (eventType == hs.caffeinate.watcher.systemDidWake) then
                local firefox = hs.application.find('Firefox')
                if (firefox == nil) then
                    firefox = hs.application.open("/Applications/Firefox.app")
                end
            end
        end
    
        local mywatcher = hs.caffeinate.watcher.new(callback)
        mywatcher:start()
        log.i("Started")
    
     
  19. blSwagger thread starter macrumors member

    Joined:
    Oct 15, 2008
    #19
    It worked! Thanks!!! Here's a copy and paste on what to do in Terminal:

    The workaround for Firefox is:

    defaults write org.mozilla.firefox NSFunctionBarAPIEnabled -bool NO

    Note that this will disable the Touch Bar for Firefox. After this bug has been fixed, you may want to re-enable it with:

    defaults delete org.mozilla.firefox NSFunctionBarAPIEnabled
     
  20. Alexanderyan macrumors member

    Alexanderyan

    Joined:
    Jul 13, 2016
  21. alex0002 macrumors 6502

    Joined:
    Jun 19, 2013
    Location:
    New Zealand
    #21
    Firefox on my Debian Linux desktop with multiple tabs open, runs for days/weeks without crashing.
    I must admit, I usually block/disable flash, but that isn't the fault of firefox if flash is buggy.
     
  22. Wildkraut macrumors 6502a

    Wildkraut

    Joined:
    Nov 8, 2015
    Location:
    Germany
    #22
    Yeah on Linux it's another story. :)
     
  23. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #23
    It doesn't appear that this issue is related to the OP. If help is wanted for this, more assistance would likely be offered for the issue if it had its own thread. You'd capture the eyes of ESET users (I'm not one) that way.

    I did take a peek at their user forum and didn't see any widespread report of crashing. If you go the uninstall/reinstall route, the instructions (US) are here. Whether the uninstall instructions remove all traces or not, I don't know.
     
  24. n8236 macrumors 65816

    Joined:
    Mar 1, 2006
    #24
    OMFG, I can't believe I haven't found this thread sooner! My rMBP from mid-2012 never had this issue. Once I purchased this tbMBP, my FireFox crashed upon every wake...SUPER FREAKIN' ANNOYIN'! Thanks for the fix!
     

Share This Page