Firefox font rendering problem persists

Discussion in 'Mac Apps and Mac App Store' started by xlopez, May 27, 2007.

  1. xlopez macrumors member

    Joined:
    Jul 13, 2006
    #1
    Hello fellow mac owners. I've been dealing with a Mozilla(Firefox and Camino) browser font rendering problem. Underlined, bold or specially formatted words show up on top of each other and other problems that basically makes sites like engadget and search engines like google(what with the keyword being bolded and underlined in the results) unreadable in some parts of the screen. I've attached two pictures to show you what I'm talking about. As you can see, links/formatted words are a pain to read. I've googled this up and found a macosxhint.com hint. I did these steps and the problem persists. I tried deactiving the duplicate fonts in the Font Book as recommended and I'm still having the same problem. The Firefox version I'm running is 2.0.0.3 and I'm using a Macbook Intel Core Duo 1.83Ghz with Mac OS X version 10.4.9 with 2GB of RAM.

    Thanks a lot for your time and for any kind of recommendations you can give for this annoying problem.
     

    Attached Files:

  2. xlopez thread starter macrumors member

    Joined:
    Jul 13, 2006
    #2
    No one?

    Well, there has to be someone dealing with the same problem... If not, can't the knowledgeable at least give me some tips regarding font issues like this one? Thanks a lot in advance!
     
  3. dernsber macrumors newbie

    Joined:
    Jun 11, 2007
    #3
    Me too..

    I've been having this problem for a while, and its really starting to annoy me. I had it fixxed for a little while, also it does it on my Desktop, but not my Laptop, same fonts setup, everything. At first i thought it was Suitcase, but sense you're having it, i'm not sure if you use a font manager.. if you do.. try removing that and reinstalling all your default fonts, see if that fixes it. If it does, then turn the font manager back on, and see if it comes back.
     
  4. Dear Lisa macrumors newbie

    Joined:
    Feb 5, 2009
    #4
    Similar...

    I had a similar problem too and it took me FOREVER to fix it! I'm on a MACbook Pro and all the resolutions were for Windows users...
    Anyway- my regular plain old Arial font had been deleted somehow. (Probably by me by accident.) Anyway- this fixed it 100%:

    Here's the download for Arial.ttf for MAC and here's what I did:

    1. Downloaded

    http://dc111.4shared.com/download/75138944/2c9f1fc3/ARIAL.TTF?tsid=20090708-124652-34fe3fe9

    it into .../Library/Fonts/

    2. I renamed Arial.ttf (instead of all CAPS just to be safe)

    3. Restart FireFox

    OPTIONALS:

    I'm not sure if I needed to do this or not but I also:

    3.a) Copied all the fonts and pasted them into a new folder
    3.b) Deleted the originals and replaced them with the copies.
    3.c) Made sure my Firefox settings under Firefox>Preferences>Content>''Fonts & Colors''>Advanced
    were
    Fonts for: __Western__
    and
    Default Character Encoding: __Western (ISO-8859-1)__

    Hope it works for you!
     

Share This Page