Firefox High CPU usage and lag

Discussion in 'OS X El Capitan (10.11)' started by Art3mis, Jun 9, 2016.

  1. Art3mis macrumors newbie

    Art3mis

    Joined:
    Dec 22, 2013
    Location:
    London
    #1
    I'm having a really strange issue with my Macbook Pro Retina right now. For some reason, when using Firefox my CPU percentage is sky rocketing over 100% and the fans are running like crazy. It only happens on certain sites so I'm not sure if it's some kind of problem with some scripts or whether ads are causing it to go like this, but it also happens when watching videos. Even when I'm casually browsing it'll be running at around 60% and idk if this was normal before but it certainly doesn't seem so?

    I've disabled Flash for now, but it's still happening regardless. I'm all up to date on the latest Firefox, and I only recently upgraded to El Capitan a couple of days ago so I don't know if it's related to the new update, but Flash was causing problems previously anyway. I've tried running it in Safe mode and the problem still persists.

    The only extensions I have running are AdBlock Plus and LastPass, I also have the following plugins - Shockwave Flash (disabled), OpenH264 Video Codec provided by Cisco Systems, Silverlight Plug In, Widevine Content Decryption Module provided by Google Inc (which came with the latest update?), Default Browser Helper, and Sharepoint Browser Plug In. I have no custom themes or anything else.

    Is there a solution to this? I was having issues with Safari before so I'm kinda loathe to go back to it, and Chrome used to cause problems for me with Flash Player too, so I don't know what to do at this point. Any ideas would be super helpful Thanks.
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Try removing all plug-ins and extensions and see if that solves the problem. If it does, add them back in one-by-one.
     
  3. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #3
    I'm still at 46.0.1 and am not experiencing high CPU usage. Did you try all the steps HERE and HERE to troubleshoot the CPU issue? Have you tried a different user account?

    I don't have Widevine Content Decryption Module provided by Google Inc as a plugin but Mozilla says:
    https://support.mozilla.org/en-US/kb/enable-drm
     
  4. Art3mis thread starter macrumors newbie

    Art3mis

    Joined:
    Dec 22, 2013
    Location:
    London
    #4
    It's definitely not my plugins or extensions. I disabled everything and tried it again and it still runs at a high percentage. I also checked all of the steps and tried them, including refreshing firefox, restarting in safe mode, clearing cookies and cache, restarting my mac, even reinstalling firefox (although it reinstalled it with my profile intact).

    Should I try and reinstall it without my profile? I don't really wanna go that far but I literally have no idea what else to try at this point. :/ I really need my bookmarks and everything so it's kind of something I'm reluctant to do. Generally it seems to spike at the highest percentage when I'm watching videos or using intensive graphics... not sure whether that is something relevant to Flash or something else, but I've tried disabling Flash to no avail. I only really noticed this problem after updating to El Capitan but then again, I wasn't really always checking the activity monitor before.

    I'm just hoping it's related more to Firefox and not my computer...
     
  5. mildocjr macrumors 65816

    #5
    It is most likely an application issue if it doesn't happen with Firefox closed. I hate to say it but Firefox has been going down hill since v3.6. You might look at trying out an alternative (Chrome, Safari) and see if you get the same issues, if so then yes you might have a problem with your computer. Most likely your culprit comes from one of the websites you are browsing running a script that Firefox can't handle gracefully.

    Just so you know, Adobe never really fixed their issue with Flash, if you can get your videos in HTML format that might be better. Chrome has a built in flash player that they did great optimizing and is my go to browser for anything flash on Mac.
     
  6. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #6
    Create a new user on your Mac and install Fx to see if it could be your Fx profile or your Mac user account.

    If it's your Fx profile, you can create a new one but still save and import All or SOME of your old profile into the new.
     
  7. Art3mis thread starter macrumors newbie

    Art3mis

    Joined:
    Dec 22, 2013
    Location:
    London
    #7
    Hm, I will have to test and see. Alot of the stuff I do on my laptop in general is just browser based or video based so I guess I might have to fire up other applications to check it out. I've been using Chrome and I've seen high usage on some sites, but it's mainly when watching videos. I'm not sure what the cpu usage should really be when it comes to watching videos usually. I don't find my computer hangs or anything, so it's not becoming a hindrance, but I notice a couple of sites use alot more memory than others.

    I figured Flash is pretty dire atm, it's why I normally disable it on every browser I'm using. I'll have to have a play around I think and see what the outcome is. :/

    This is probably a good idea, I'll have to try it. I'm wondering if it is my Mac User Account.... I don't know if most of these issues are application based or due to a problem with the laptop itself. I'm not really sure what usage it should really be running at in general.
     
  8. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #8
    Please share the URL of an affected page.

    If you wish to push hard: http://forums.macrumors.com/posts/22970709 includes a link to a page that probably includes hundreds of thousands of links.
     

Share This Page