Firefox - How to stop video Autoplay when opened in new tab

ashy7

macrumors newbie
Original poster
Aug 9, 2010
19
0
Hi All,

I bought a 2.4Ghz MacBook pro last week. It is my first Mac, and I am slowly getting used to it. I have a couple of questions that I hope you can help me out with (I have searched but found no answers!):

1) In Firefox on my old PC, and Safari on the current Mac, if I open a video in a new tab, the video would not auto-play, until I clicked on the tab. On Firefox on the Mac the video just auto plays. This is pretty annoying when I open 4 or 5 videos in different tabs and they all start playing. I want to click on the tab before it starts playing.

As safari on the Mac does not play the videos automatically, I am hoping there is a way to stop it on Firefox?

2) I know that holding cmd and clicking on a link opens it in a new window, but is it possible to assign for example a 3 finger click to open a link in a new tab?


Cheers
Ash
 

ashy7

macrumors newbie
Original poster
Aug 9, 2010
19
0
I came across that while I was doing a search. The following comment from the developer didn't fill me with much confidence though:

"I don't have time to maintain Stop Autoplay. The extension is still buggy and the code needs to be rewritten, but that is beyond my ability. I am looking for someone to take over the development. If you are interesting in this extension, feel free to take it, you don't need to tell me. I appreciate your help."


I am hoping there is a more reliable fix.
 

clevin

macrumors G3
Aug 6, 2006
9,095
1
an example would be helpful, maybe a link to a video you would it not to autoplay.

in the mean time, try goto about:config and change value of media.autoplay.enabled to false.
 

Attachments

ashy7

macrumors newbie
Original poster
Aug 9, 2010
19
0
So an example is metacafe.com. If you open a video in a new tab, the video will start playing automatically, whether you click on the tab or not.

If you open up the same site in safari, and open the video in a new tab, the video will only start playing once you have clicked on the tab.

I tried changing the config file, but it didn't work.
 

clevin

macrumors G3
Aug 6, 2006
9,095
1
that addon might be your only shot. try it out, it wont eat your browser.
 

ashy7

macrumors newbie
Original poster
Aug 9, 2010
19
0
I'll give it a go, but I think I might just give Safari a try and see how I get along with that.
 

Similar threads

  • mac59
0
Replies
0
Views
217
  • Washac
0
Replies
0
Views
259
  • zalle
6
Replies
6
Views
522
Replies
1
Views
305
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.