Firefox icon in dock

Discussion in 'Community Discussion' started by aptroed, Jan 14, 2012.

  1. aptroed macrumors newbie

    Joined:
    Feb 20, 2011
    #1
    Hi all. I am new to this forum, so please be patient if I am really dumb

    I am running a Macbook Pro, OS X, 10.6.8, and after a recent update, my Firefox icon in the the dock changed to something that looks like a text edit icon, but with a white zero with a slash through the center. Anyway, I have consulted Mac help and this forum on how to change this specific icon, but nothing covers the issue. My Firefox icon is correct in Finder, and in my Applications folder, but incorrect on the Dock. All the other icons are correct.Can anyone help me change this? Thanks. peter
     
  2. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #2
    Does it still work when you click on it in the dock?

    Is it set to stay in the dock or only show up when it's running?
     
  3. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #3
    Were you running Firefox from the DMG? I am guessing that is what you did, and while FF was open, you clicked on it in the Dock and told it to Keep in Dock.

    Does that sound right? if so, you'll need to either run the DMG or download the latest version and then move the FF app from the DMG to your Applications folder. Then you can tell FF to keep in Dock and it will work properly.

    You can Remove from Dock the white slash icon. It looks that way because it doesn't know where the application is anymore.
     
  4. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #4
    Right click (control+click) the white icon. Options - remove from dock. Or drag it off the dock.

    Go to your applications folder in finder and drag it to the dock. Finished :)
     
  5. aptroed thread starter macrumors newbie

    Joined:
    Feb 20, 2011
    #5
    Thanks

    Thanks to all.
    I deleted the present incorrect icon from the dock by dragging it off.
    Then I dragged the new correct icon from the Finder to the Dock, and Bingo, it remains as the correct Firefox icon.
    Thanks to all for responding!!
     

Share This Page