Firefox / Intel Mac / Java not working

Discussion in 'Mac Apps and Mac App Store' started by tzurita, Oct 27, 2006.

  1. tzurita macrumors newbie

    Oct 27, 2006
    After installing Firefox 2.0 I go to http://about:plugins and see:

    Java Embedding Plugin 0.9.5+g+2

    If I check Java version on command line I get:

    Legion-Computer:~ tzurita$ java -version
    java version "1.5.0_06"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-112)
    Java HotSpot(TM) Client VM (build 1.5.0_06-64, mixed mode, sharing)

    If I go to

    Ok, Thanks for the responses thus far, to update all, I have done more than the suggestions given. I investigated further and found that Safari, had the same problem. I went to the "Mac Genius Bar" and checked out a vanilla install of OS X 10.4.8. Theirs worked.

    By this point I had:
    Disabled all plugins that I added
    Removed Firefox
    Re-added Firefox
    Reinstalled Safari
    - Tried this by removing Receipts (didn't work)
    - Then just mounted the CD cd'ed to the Volume and pulled the safari.pkg out and installed it individual package
    Then I backed everything up to an external drive and reinstalled OS X 10.4, patched, restored my home dir and settings (minus plugins)

    Voila, Java was seen by both Safari and Firefox

    I get nothing.

    I used the MRJPlugin.plugin with Firefox 1.5 and, although I had the same java (1.5) installed it said that I had 1.3 installed. I never knew how to make the plugin see the later version. I also had to open the plugin using Rosetta, for 2.0 I am not opening using Rosetta.

    If anybody has a suggestion I would appreciate it. BTW, I have uninstalled and reinstalled. Certain sites do work but I am having a problem with certain sites, the error is:

    Your session expired. Please reload this applet by pressing your browsers "Reload" button to restart this session​

    From what I know this is normally a cookie session/security problem but I don't believe that is the case here and I am unsure of where to start investigating. If anybody has solved a similar issue, please assist.
  2. Mitthrawnuruodo Moderator emeritus


    Mar 10, 2004
    Bergen, Norway
    Look into /Library/Internet Plug-ins/ and remove any 3rd party Java plug-ins (like the one mentioned above).

    I have no problems with these plug-ins installed:

    Picture 2.jpg

    The test page seems to work nicely (once I got rid of the ':' at the end of your link):

    Picture 1.jpg
  3. zero2dash macrumors 6502a


    Jul 6, 2006
    Fenton, MO
    I've always had problems with Firefox not working with Java (in both Windows and OSX).

Share This Page