Firefox issues. Help

Discussion in 'Web Design and Development' started by chelseasian, Dec 13, 2007.

  1. chelseasian macrumors regular

    chelseasian

    Joined:
    Oct 20, 2004
    Location:
    New York, NY (Chelsea)
    #1
    Hi!

    I just helped insert a video from YOutube onto this page- http://marlboropw.com/Cheerleading/index.html

    but it is not showing up. I tested locally on my Mac and it works but when it is on the server, I cannot seem to get the video show up.

    Is there something wrong with my coding somewhere?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Potential Firefox Bug

    Well I was able to view the video with Firefox (2.0.0.11) on Mac (10.4), but only after the page loaded then disappeared. So the video was the only thing on the page, but did play correctly. Page does work in Safari 3 and Opera 9.

    Using the Firefox Web Developer Toolbar extension I used the View Generated Source option and saw that it confirmed what I thought, only the code for the movie was inside the body tag. The linked script for displaying the video code uses document.write lines. I've found in certain circumstances this will start writing on a new page, rather than adding to the current page. This generally happens when the code is run from inside the head tag, which is not what you're doing so not sure why it's happening. If the code used the innerHTML technique instead this would bypass the problem, but not much you can do about that, and shouldn't be necessary.

    This could be a Firefox bug potentially. Perhaps someone will be able to use my analysis here to come to a better answer and solution.
     

Share This Page