Firefox keeps redirecting me.

Discussion in 'macOS' started by knokbula, Jul 12, 2008.

  1. knokbula macrumors newbie

    Joined:
    Jul 12, 2008
    #1
    When I do a google search the first link i click always sends me to the wrong place; but then if go back to the google search results page and click the link, it works.

    I also have this problem randomly on various other sites, but when I try clicking the link again, it does not work; google search results pages are the only pages on which re-clicking the link gets me where I want to go.

    I mentioned this to a friend over the MSN, and he (forgetting that I have a mac) said that I should get spyware and adaware. When I searched for mac versions of said programs I only found reports that said such programs do not exist, and that Macs should not ever need them.

    After reading that, the next report I found brought me to this site, and I figured that this site would be a good place to ask about my problem, so I did.

    I also can't load the basic firefox/google homepage (http://www.google.ca/firefox?client=firefox-a&rls=org.mozilla:en-US:eek:fficial
    ). I do not know if this problem is related to the aforementioned problems.

    How can I fix my internets?

    Plz help KTHXBAI
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    It sounds like split links. Some websites will create a link that, when you click it the first time (and with some, 2 or 3 or 4 times), it redirects you to an advertising partner. Some are really obnoxious and never send you to the desired location, but only to other sites, where they get paid for each click-through. It's a way to artificially create clicks for more revenue. Get the Firefox add-on called SplitLink and then you can right-click on such a link and select which redirected link you want.

    As for the Firefox/Google link you posted, it worked fine for me on Safari.
     

    Attached Files:

  3. knokbula thread starter macrumors newbie

    Joined:
    Jul 12, 2008
    #3

    I tried clicking this link; it worked fine, and I clicked the "Download now" button; which sent me to a new page that said "Thank you for downloading SplitLink 2.0.7" but it never downloaded. Then, after a few seconds, firefox alerted me that it had stopped the page from trying to open a pop-up window; which I figure was the pop-up to click 'save link as' and then select the location to download said software onto my computer.

    I hit the preferences button to allow pop-ups for that page, but nothing happened.

    I retried this several time, but still nothing.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    It appears that SplitLink, which used to be available through the Firefox Add-Ons, has moved to other methods of access. Try this link from this page and see if it works. It downloaded fine for me. Also, it says it works with Firefox 2, but doesn't say if it will work with Firefox 3. I don't know which version you're using, but it can't hurt to try it out.
     
  5. Hates macrumors regular

    Joined:
    Jul 10, 2008
    Location:
    London, UK
    #5
    My mum had something similar sounding happen to her FF. I just cleared the cache and private data and it seemed to start working again.
     

Share This Page