Firefox -- laggy scrolling??

Discussion in 'Mac Apps and Mac App Store' started by jon08, Jan 9, 2012.

  1. jon08 macrumors 68000

    Joined:
    Nov 14, 2008
    #1
    Does anyone experience kind of laggy scrolling in Firefox? I'm using v. 9.0.1 and it's kind of hard to explain the problem - but when I scroll up and down (esp. when doing it slowly), it's like it's skipping thin layers on the screen. For example, I scroll down, and the screen obviously goes up and the whole process is not that smooth (even with smooth scrolling ticked).

    In Chrome or Safari there are no such issues. I've tried creating a new profile and reinstalling Firefox, but to no avail.

    And by the way, scrolling seems to be fine in Safe Mode!

    The only add-ons I'm currently using are:

    - 1P
    - ABP
    - Stylish
    - Read It Later

    However, I tried disabling the add-ons only, but it didn't do the trick.

    Anyone else experiencing anything similar??
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Try toggling hardware acceleration on/off in Firefox's preferences.
     
  3. jon08 thread starter macrumors 68000

    Joined:
    Nov 14, 2008
    #3
    Wow, it seems to have helped turning it off!

    But why? It's not like it should lag at all with my MBP configuration........
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    It depends on if your MBP is one of the newer ones that has both integrated and discrete graphics. If this is the case, and your computer is in integrated mode, this can occur due to driver bugs. Forcing Firefox into software rendering mode fixes it.
     
  5. jon08 thread starter macrumors 68000

    Joined:
    Nov 14, 2008
    #5
    Yes, it's the one that's in my signature -- and since it's hooked to the external monitor it's basically always using the dedicated GPU. Why would then hardware acceleration be problematic in this case?
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    Well that is odd indeed! I am not sure. If I were you I'd report the bug to Mozilla (after checking if it is already there) and testing Firefox Beta / Aurora / Nightly to see if the issue is fixed there.
     

Share This Page