Firefox makes 'funk' sound when opening

Discussion in 'Mac Apps and Mac App Store' started by thecounthahaha, Aug 9, 2016.

  1. thecounthahaha macrumors regular

    Jul 17, 2010

    I've been having an issue where my firefox makes the apple 'funk' sound when opening. No other apps do this though...

    Here's a website that seems to be the same problem, but its a windows XP thing!

    I've disabled all my plugins and the sound is still there. Does anyone have any ideas what it might be?

  2. rshrugged macrumors 6502a

    Oct 11, 2015
    Try to remember when this started happening. Software updates? New computer software or add-ons for Fx?

    Are you being directed to pages other than what you've chosen at -- Fx Preferences -> General -> When Firefox starts -- ? That would point to adware. Most here use Malwarebytes for Mac as a cleaning tool.

    If not, I did find an occurrence on Mac reported at Mozilla support, HERE. In that user's case, it appears an add-on was the cause. Clear cookies and cache; try starting Fx in Safe Mode to see if the sound goes away. A side test to see if it's your profile -- create a new user account or check a different existing one.

    There's a number of troubleshooting steps you can take, again assuming it's not adware, the quickest being refresh or reinstall. In either of those, as part of their process, you can save most of your important data. You can also actually drag items from your old, saved profile to have a complete save, but you risk dragging the unwanted sound into your new profile.
    --- Post Merged, Aug 10, 2016 ---
    Of course, make sure the sound isn't Fx notifying you to update.

    Another thought occurred to me. Outside chance, but if you recently updated OS X or Fx, I suppose some corruption could occur between an app and OS X Notifications.
    System Preferences -> Notifications -> for Fx if ticked, untick Play sound for notifications
  3. thecounthahaha thread starter macrumors regular

    Jul 17, 2010
    Wow thanks for all the help!

    I can't think of anything specific - I have installed a handful of addons, but have since turned them off, but I can't work out whether it was before or after the beeping started.

    I've cleared cache and cookies to no avail. Restarting in safe mode makes the sound go away though. Turning off all of my installed plugins does not however, with the sound still there.

    Notification sounds were indeed on in system prefs, but turning it off does not affect this beep.

    I use firefox sync, and my other mac does not have beeping - would the quickest method be to sync, uninstall and then reinstall firefox?

  4. rshrugged macrumors 6502a

    Oct 11, 2015
    Yes, but after you sync I would exit sync before uninstalling/reinstalling.

    A reinstall should maintain your user profile but having a backup plan is always in order. Keep us posted. : -)

    Most of the stuff which is stored in your profile --

Share This Page