Firefox messed up menu

Discussion in 'Mac Apps and Mac App Store' started by MacBH928, Sep 7, 2010.

  1. MacBH928 macrumors 68020

    MacBH928

    Joined:
    May 17, 2008
    #1
    Hello,

    I installed firefox on my mac snow leopard , and my bookmark menu is kind of screwed up with german kind of text, take a look:
    [​IMG]

    how can I fix this please?
     
  2. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Maybe try uninstalling the Albanian version of FF and installing the US version! :):)
     
  3. MacBH928 thread starter macrumors 68020

    MacBH928

    Joined:
    May 17, 2008
    #3
    I did install the world version, or all languages version.

    But i went back to download the English only version, and replaced it with the current one I have, but no use.

    How can I delete the older version, without losing my passwords, bookmarks, and other information?


    ********
    Why can't I just wait for firefox 4 to get out of beta?
    beta usually means problematic
     
  4. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    You first installed the world version, and then you installed the English-only version? And the bookmarks menu still contains Albanian words?

    If this correctly describes the situation, then I suggest that you try the following:

    1) Quit Firefox.

    2) Locate the file named org.mozilla.firefox.plist in the Library/Preferences folder inside your Home folder and move that file to your Desktop. (Bookmarks and passwords are stored elsewhere.)

    3) Start Firefox and see if the menu problem is fixed. If so, I'd trash the file you moved to your Desktop. If the problem remains, you could move that file back where you found it (or just trash it).

    [EDIT] Your bookmark and password data should be inside the Library/Application Support/Firefox/Profiles folder within your Home folder, so do not delete this folder. However, the menu problem may be related to a particular item inside this folder.
     
  5. MacBH928 thread starter macrumors 68020

    MacBH928

    Joined:
    May 17, 2008
    #5
    I did as you told me, it didn't work.
    When I launched firefox, it created that file again in the preferences directory.
    I even trashed the original, still no use.

    I highly appreciate your care to help,
    but I am still looking for a solution :(
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    It is normal for Firefox to re-create that preferences file. Since your problem remains, it is not caused by anything in that file. At this point I suggest that you seek help at the Firefox support forum. My guess is that there is a specific file in your Profiles folder that is causing the problem.
     
  7. Caleb531 macrumors 6502

    Caleb531

    Joined:
    Oct 17, 2009
    #7
    Have you tried renaming those bookmarks?

    Etiketa së Fundmi = Recent Tags
    Faqeruajtur së Fundmi = Recently Bookmarked
     
  8. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #8
    Of course, the simple approach!
     
  9. MacBH928 thread starter macrumors 68020

    MacBH928

    Joined:
    May 17, 2008
    #9
    what do you know
    I changed the names it worked!
    I didn't know you can do that!

    thanx for the help everyone, will pass on the karma!
     

Share This Page