Firefox not adding .com/.net/etc to site URL, plz help :(

n8236

macrumors 65816
Original poster
Mar 1, 2006
1,039
8
I don't know when this started happening, but I used to be able to visit sites (ie Apple.Com) by just typing "apple" in the URL bar.

But now Firefox isn't automatically adding ".com" or anything to the end of the site names and directing me to some useless site. It's doing this for all sites. Having to type .com to every site is a pain in the ass.

How can i fix this? :confused:
 

defeated

macrumors regular
Feb 22, 2007
188
0
which site do you get by just typing "apple" in address bar followed by enter?

when you only input a string without .com/.net, etc, firefox will do an automatic google search and bring you to the top result (mostly).

If you want it to add ".com" automatically, after inputting the address, you need to press "cmd+enter" instead of just "enter".

You can also change the ".com" to anything (such as ".net", ".info", ".br", ".crazy" :), etc) by changing the value of "browser.fixup.alternate.suffix" in about:config settings.
 

n8236

macrumors 65816
Original poster
Mar 1, 2006
1,039
8
which site do you get by just typing "apple" in address bar followed by enter?

when you only input a string without .com/.net, etc, firefox will do an automatic google search and bring you to the top result (mostly).

If you want it to add ".com" automatically, after inputting the address, you need to press "cmd+enter" instead of just "enter".

You can also change the ".com" to anything (such as ".net", ".info", ".br", ".crazy" :), etc) by changing the value of "browser.fixup.alternate.suffix" in about:config settings.
Just some advertisement directory site. It goes there for any site I type in w/o a suffix.

It used to fill in the .com/.net/etc, just not anymore. I never had to press cmd+enter, enter alone used to work fine.

Lemme play w/ the about:config settings. I'll report back.

Also, I just installed Ubuntu on my desktop and it's doing the same thing on that too! I wonder if it's the new Firefox update (that arrived today) which screwed it up >.<
 

alb halfegg

macrumors newbie
Jun 29, 2008
2
0
.com end suffix

Hey people thank me for taking the time to register on these forums for the sole reason, that to help.


just found out how to restore the automated .com suffix input.

type: about:config type: keyword.url and change the google link (i cannot remember now) to: .com


http://youtube.com/watch?v=aLgOdP1tQi0

Greeting
 

pjrobertson

macrumors 6502a
Nov 14, 2007
533
4
I always thought that if you just typed in something like 'apple' Firefox would search Google's using the 'I'm feeling lucky' option and take you to the best hit (if there is one available)

type in "macrumors forums" and it takes you to forums.macrumors.com

If all the sites you visit are com, then you might as well turn on the option in about:config.

With FF3, once you've visited the site once it should be easy to find in the new 'smart location bar'
 

alb halfegg

macrumors newbie
Jun 29, 2008
2
0
firefox end suffix

Updated post how to restore previous firefox system of end suffix term guessing .com/org/net...


location bar, type:- about:config
search for: keyword.url and change the google/yahoo link not to .com but to:

<>http://www.google.co.uk/search?hl=&btnI=I%27m+Feeling+Lucky&meta=en&q=<>
(ignore the empty tags <>)


greetings