Firefox opens itself to answers.com

Discussion in 'macOS' started by MacMav, Dec 2, 2011.

  1. MacMav macrumors newbie

    Joined:
    Dec 2, 2011
    #1
    Hi,

    I am happy to have found a mac forum. I was writing up my dissertation and looking away from the screen with no buttons pressed on my keyboard when firefox opened itself automatically. I had Safari opened and I was visiting academic sites only.

    My default browser is Safari and I don't use Firefox as much. The question is has my mac been hacked? I apologies for asking this question that has probably been asked a million times but I am a bit cautious when entering any personal details using this mac.

    It did this twice and has never done it before, the mac is running slow as usual and it only happened with firefox opening answers.com.

    I would really appreciate a reply.

    Thank you
    MacMaV
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    No, your Mac hasn't been hacked. And no, you don't have a virus. You don't need any 3rd party antivirus software to protect Mac OS X from malware. Macs are not immune to malware, but no true viruses exist in the wild that can run on Mac OS X, and there never have been any since it was released 10 years ago. The only malware in the wild that can affect Mac OS X is a handful of trojans, which can be easily avoided with some basic education, common sense and care in what software you install. Also, Mac OS X Snow Leopard and Lion have anti-malware protection built in, further reducing the need for 3rd party antivirus apps.
    Read the section "Why am I being redirected to other sites?" in the link above.

    Check your Login Items under System Preferences > Accounts to see if you have Firefox automatically launching. Also, check to see what home page you have set in Firefox preferences.
     
  3. MacMav thread starter macrumors newbie

    Joined:
    Dec 2, 2011
    #3
    Thanks for your reply,

    My mac is getting even weirder, again I have not done anything to it in terms of changing any settings. I woke the mac up and opened MS Word and I was presented with a dialog box that said "do you want the application MS word to accept incoming network connections". I didn't accept or decline and the dialog box disappeared.

    I then noticed my system profiler was opened with todays date and the time was 07:16pm 4 hours ago. What is going on? Why is this happening now? I did delete my av as it was Sophos so maybe that is why the system profiler showed up.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    That's normal. Your firewall is simply asking if you want Word to accept connections, which it's fine to say OK.
    Check your date and time settings in System Preferences.
    Smart move. Sophos should be avoided, as it could actually increase your Mac's vulnerability, as described here and here... and here.
     

Share This Page