Firefox question

Discussion in 'Mac Apps and Mac App Store' started by 4God, Aug 21, 2009.

  1. 4God macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #1
    Okay, so when I launch Firefox it gives me a popup that says "A copy of Firefox is already open. Only one copy of Firefox can be open at a time."
    I've tried repairing permissions and it still gives me the same error. It only does this on one of three users. Help?
     
  2. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    White Mntns, Arizona
    #2
    Try going to System Preferences, then Accounts. Under the Login Items tab does Firefox show there? Maybe somehow it got setup to launch when you login.
     
  3. 4God thread starter macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #3
    Thanks, tried that already too. Firefox doesn't actually startup at login and the little blue dot under the dock icon isn't there either. It launches fine in the other two user accounts, this really has me stumped. I've even tried making sure that the other users are logged off as well.
     
  4. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #4
    Try using an app like AppTrap to completely get rid of firefox, and then reinstall it. :)
     
  5. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #5
    ^^ Yeah, it may be an errant lock file or something.

    Try this...

    http://home.att.net/~cherokee67/ffwontstart.html

    Look for a .parentlock file in your FF profile and delete it, if it exists. (It will be invisible in Finder unless you turn on showing hidden files, so either do that or use terminal).
     
  6. 4God thread starter macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #6
    Tried both and I'm still having the same problem. This is really driving me nuts.
     
  7. creon macrumors 6502

    Joined:
    Mar 19, 2009
    #7
    Who Uses FF? Safari is the only way for me to browse! Gotta love the trackpad gestures!
     
  8. 4God thread starter macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #8
    Well I'll probably go back to just using Safari anyways, it's just that it seems kinda weird that this is happening with FF. Plus, I would like to fix this seemingly simple issue anyway.
     
  9. creon macrumors 6502

    Joined:
    Mar 19, 2009
    #9
    I know how that use to feel in Windows. All is fine but, WHAT THE HELL IS THIS THING DOING! Can't ignore the elephant in the corner.
     
  10. mrmayor92 macrumors 6502

    Joined:
    Jul 12, 2008
    Location:
    PA
    #10
    you can enable gestures in firefox too (twist left to go to left tab etc) and 3 finger stroll to jump to the bottom of the page and vise versa.

    and OP try uninstalling and reinstalling firefox
     
  11. creon macrumors 6502

    Joined:
    Mar 19, 2009
    #11
    and cart-wheel right to go forward?

    No, thanks.
     
  12. mrmayor92 macrumors 6502

    Joined:
    Jul 12, 2008
    Location:
    PA
    #12
    its actually really intuitive once you get used to using it
     
  13. creon macrumors 6502

    Joined:
    Mar 19, 2009
    #13
    I'll give it a try and see how it feels. With SL coming out it will be a dead race to see what browser will win my love...and i guess safari is going to get a lot more snappier.
     
  14. mrmayor92 macrumors 6502

    Joined:
    Jul 12, 2008
    Location:
    PA
    #14
    alright you can to mod the about:config to do it but its reallllllly easy

    link for reference
    http://www.wired.com/gadgetlab/2008/12/firefox-adds-mu/
     
  15. 4God thread starter macrumors 68020

    4God

    Joined:
    Apr 5, 2005
    Location:
    My Mac
    #15
    Thanks, that was the first thing I tried. I've given up on FF, I'll stick to Safari with my new SL when it arrives today.
     

Share This Page