Firefox Quits, Unusable

Discussion in 'MacBook Pro' started by tam5070, Jan 6, 2011.

  1. tam5070 macrumors newbie

    Joined:
    Jul 4, 2008
    #1
    So I've had issues with firefox since maybe a year ago. I'm a dedicated chrome user though so I haven't cared that much. Now I need firefox for specific sites I need to use for work/school.

    Whenever I open firefox, it's extremely sluggish to begin with but will normally open to a home page. Then after a few pages, or trying to log in to a site, it wil "quit unexpectedly." This is the screen and error report I receive.

    http://img98.imageshack.us/img98/1731/screenshot20110106at916.jpg

    I'm running 10.6.5 with a 2.5 GHz intel core 2 duo, 4 GB 667 MHz aftermarket ram (don't think the ram is the issue, problems persisted before ram was installed).

    I've tried uninstalling reinstalling, using appzapper to remove every file, manually taking out the application support folders, nothing seems to work. I'm doing disk repairs now with disk utility and will try a PRAM and an SMC reset, but don't have high hopes.

    Any solutions?
     
  2. NickZac macrumors 68000

    NickZac

    Joined:
    Dec 11, 2010
    #2
    If the FF version you are using is Beta4, that is why. The newest Beta release does some really weird things. I used it for a week to review and found all sorts of issues, concluding that Beta4 is less suited to Macs than any previous version. (keep in mind the Beta release is not the final and most Beta programs do have issues which are worked out over time with usage)
     
  3. tam5070 thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #3
    I'm not using the beta, using the current stable release. Without looking I think it's like 3.6.x or something but its whatevers current
     
  4. LPZ, Jan 7, 2011
    Last edited: Jan 7, 2011

    LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #4
    According to the crash report, you're running Version 3.0 for Power PC. Since you have an Intel cpu, it's running under Rosetta. You need to get version 3.6.13 for Mac OS X Intel.

    [EDIT]Maybe you mistakenly set Firefox to open using Rosetta? Click on the Firefox icon in your Applications folder and then do command-I and check.
     
  5. tam5070 thread starter macrumors newbie

    Joined:
    Jul 4, 2008
    #5
    I actually noticed that it said PPC version on there but I was confused. I'm running snow leopard which I was under the impression took off all Rosetta capabilities (or something like that). I'll look around for the Intel version, didn't realize I'd have to actively seek it out and it wouldn't be the default.

    I just downloaded the 4 beta too and I'm testing that out currently.

    Will report back when I get the Intel version, thank you guys for your help and patience. MR is such a great and useful community, hope I can be as helpful in the future.
     
  6. LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #6
    You may have the correct version, but it's a universal binary that can run either on Intel or PPC. See if you set Firefox to open using Rosetta.
     

Share This Page