Firefox Search History

Discussion in 'Mac Apps and Mac App Store' started by MacUser2001, Aug 5, 2007.

  1. MacUser2001 macrumors newbie

    Joined:
    Aug 5, 2007
    #1
    I'm having trouble clearing my google search history that appears in the drop-down list of the search box in Firefox. I have tried the usual method of clearing private data, including "Saved Form and Search History," but it had no effect. I also tried re-installing Firefox, and even that did nothing. If anyone can help me with this problem I would be very grateful. :confused:
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    Are you sure you're seeing previous results and not "suggestions?" What about right clicking in the search bar (or control clicking or two-finger tapping, to get the contextual menu) and then selecting the clear search history item that's there?
     
  3. MacUser2001 thread starter macrumors newbie

    Joined:
    Aug 5, 2007
    #3
    I'm sure that it's not just suggestions, and right clicking only yields that option when I right click on the Google toolbar, not the actual Google search page. I think there may be some sort of glitch with my Firefox, perhaps I need to uninstall more than just the core application to delete all content because it retained all add-ons and bookmarks etc. when I reinstalled the first time.
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    Wait, what search box are you talking about? Do you mean the search bar in the upper right corner of the Firefox window, one in another toolbar you added, or one on the google.com webpage (inside the webpage)? You might need to trash your Google cookie.
     
  5. MacUser2001 thread starter macrumors newbie

    Joined:
    Aug 5, 2007
    #5
    I'm talking about the one in the Google webpage. I've cleared everything including cookies using "Clear Private Data" under Tools.
     
  6. MacUser2001 thread starter macrumors newbie

    Joined:
    Aug 5, 2007
    #6
    Oh wow, I don't have an explanation as to why it worked this time, but I just tried again and it seems to have worked... Strange. Sorry for wasting your time!
     

Share This Page