Firefox Uber-slow While Using "Better Battery Life'

Discussion in 'Mac Apps and Mac App Store' started by zflauaus, Aug 2, 2007.

  1. zflauaus macrumors 65816

    Joined:
    Nov 19, 2004
    #1
    I love Firefox. It does everything I need and I love the extensions in it. One thing I don't like: how slow it is while on "Better Battery Life."

    I can rarely have more than one tab open and have it snap smoothly. If I set it on "Normal" while using the battery, then it works fine. There are only about 5 extentions running (FasterFox, Adblock, Adblock Updater, ForecastFox, DOM Inspector).

    Is Firefox just a huge performance hog or are the extentions taking a toll on it?
     
  2. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #2
    if your firefox runs fine with normal battery setting, and runs crappy with "Better Battery Life.", the problem have to be system related.

    Although its beyond my imagination why would there be any difference simply caused by battery settings.
     
  3. zflauaus thread starter macrumors 65816

    Joined:
    Nov 19, 2004
    #3
    I was wondering if it was my computer. I have been thinking of reinstalling OS X because it seems like it's been slowing down, even when I ran the OnyX scripts and whatnot. Guess another reason to add to the list.
     
  4. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #4
    I bought my MB during OSX 10.4.7 time, and each patch from apple makes it a little bit slower. Now my Adium won't quit until I force it. and beachball shows up more frequently even with 2G RAM, :eek:

    But I have too much data on disk, can't do re-install for now. maybe later..
     
  5. kick52 macrumors member

    Joined:
    Aug 2, 2007
    Location:
    England
    #5
    afaik, "Better battery life" switches the CPU to a lower level of performance. (At least thats what happens on my iBook)

    So it could be that.
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #6
    OSX's CPU always works at variable frequency, not max most of the time, I highly doubt that is the reason.
     

Share This Page