Firefox won't remember what pages I've visited on Google

Discussion in 'Mac Apps and Mac App Store' started by Island Roots, Dec 27, 2008.

  1. Island Roots macrumors regular

    Joined:
    Sep 26, 2003
    #1
    When I use Google to search for something and click on a result, then navigate back to the search results, the link that I just clicked shows up as visited (it is a different color). However when I refresh the results or search for the same results again, that very same webpage shows up as unvisited (same color as all other links on the page).

    I've narrowed this down to specifically an issue with Google, or at least not browser-wide (visited links are being remembered on CNN.com).

    I'm using Firefox 3.0.5, history is being remembered for 30 days in preferences.

    Any ideas?

    I've tried logging out of Google and searching as a guest and it still doesn't work. I've verified that it works correctly in Safari.
     
  2. Slowstick macrumors 6502

    Joined:
    Dec 16, 2008
    #2
    Is the "always clear my private data when I close Firefox" box checked under Preferences? Make sure that box is unchecked. You can find that option under privacy in FireFox preferences.
     
  3. Island Roots thread starter macrumors regular

    Joined:
    Sep 26, 2003
    #3
    Nope, that is not checked.

    As I said, other websites are remembering visited pages, such as CNN.com.
     
  4. keven77 macrumors newbie

    Joined:
    Apr 2, 2009
    #4
    I'm having the exact same problem. Here's my situation:
    - I do a Google search and click one of the resulting links.
    - Hit the back button and Google search results display the visited link in purple.
    - Close that window and open a new one.
    - Do the same search.
    - Visited link is now blue.

    At first I didn't realize it was specific to Google but then I cam across your post and tested the same thing in Yahoo which worked fine.

    My history setting is set to "Keep my history for at least 90 days".
    "Always clear my private date when I close Firefox" (under the Private Data preference) is not checked.
    I've also tried starting in Safe Mode but that didn't help either.
     
  5. Island Roots thread starter macrumors regular

    Joined:
    Sep 26, 2003
    #5
    I fixed this somehow but I cannot remember for the life of me what I did.
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
    #6
    i can't confirm this, with either 3.0.8, shiretoko, or minefield.
     
  7. Island Roots thread starter macrumors regular

    Joined:
    Sep 26, 2003
    #7
    This happened to me again and I figured out the solution (it doesn't make sense but works).

    Go into preferences, open up the list of cookies, search for 'google' and delete all cookies associated with Google.

    Fixed. Visited links are remembered.
     

Share This Page