Firefox works, all other browsers don't - Help?

Discussion in 'Mac Apps and Mac App Store' started by gsturner, Aug 3, 2007.

  1. gsturner macrumors newbie

    Joined:
    Aug 3, 2007
    #1
    I'm using an iBook G4 running OS X 10.4.7. Firefox works fine (well, its usual buggy fine...) but all other browsers refuse to connect. Safari gives me this:

    *****
    Safari can’t open the page.
    Safari could not open the page “http://my.yahoo.com/” because the server stopped responding.
    *****

    and IE and Camino also give me similar messages.

    Any idea what could be happening? All the information I've found online is for when no browsers at all can connect.

    Thanks.
     
  2. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #2
    Check the proxy settings in Firefox and replicate them into the OSX System Preferences, which should allow Camino and Safari to work. IE, like Firefox, has its own settings.
     
  3. gsturner thread starter macrumors newbie

    Joined:
    Aug 3, 2007
    #3
    I tried that but Firefox's Proxy option ("Direct connection to the Internet") is not available for the general network settings--they just have "manual" and "using a PAC file". It's on "Manual" per Comcast's instructions.

    I have a desktop machine connected to the Internet via the same Airport Express and that one can start Safari without difficulty The only different between the two connections is that the desktop gets an IPv4 address using DHCP and the laptop (the one that can't start Safari or Camino) gets an IPv6 address automatically.

    Could that be the problem?
     
  4. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #4
    It shouldn't be. An interface can get both types of addresses. Also if the laptop didn't get an IPv4 address Firefox wouldn't work on it either. Is there any differences in the DNS servers configured in the Network prefs of each machine (it's in the TCP/IP panel)?
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    Set Sys Prefs to Manual and untick everything on the left, and see what happens.
     

Share This Page