Firevault startup time

Discussion in 'macOS Sierra (10.12)' started by Samtb, Dec 24, 2016.

  1. Samtb macrumors 65816

    Joined:
    Jan 6, 2013
    #1
    Does enabling firevault slow down boot up or start up from the login screen?
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    I do not notice any startup slow down. Our household has a 2014 & 2015 MBP, the 2014 has FileVault enabled and the 2015 does not. The 2014 FileVault MBP boots just as fast as the non-FileVault MBP after login.
     
  3. Samtb thread starter macrumors 65816

    Joined:
    Jan 6, 2013
    #3
    I find that since I enabled it, after entering my password on the login screen, a progress bar comes up. That didn't happen before. It used to just go straight to the home screen.
     
  4. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #4
    Yes, that's normal. It adds only a few secs or so to a non-FV login.
     
  5. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #5
    Yes, the decrypt happens after entering the login password. The time it takes depends on hardware. My MacBook Air or Retina MacBook with PCIe SSDs go through it quickly enough that it's not an issue. If you have a hard drive, it'll take longer. But really, how often do you do a full restart? It's worth the wait for data security.
     
  6. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #6
    I slightly mis-spoke. The whole startup process is about the same time, but in a different order. You should see the load bar either way, just in a different order.

    2014 MBP with FileVault:
    Press Start button
    Almost instant Login screen
    Enter password
    Load bar displayed while FileVault decrypts and loads system

    2015 MBP without FileVault:
    Press Start button
    Load bar displayed
    Login screen
    Enter password
    Spin wheel displayed momentarily while loads system

    It seems like about the same overall time to me.
     

Share This Page