Firewall application exceptions: dialog disappears strangely

Discussion in 'macOS' started by Vicegrip, Sep 9, 2009.

  1. Vicegrip macrumors newbie

    Jul 15, 2008
    OSX: Snow Leopard

    Recently, the "allow application to accept internet connections" dialog has been disappearing as soon at it appears without any interaction on my part.

    I've verified my firewall configurations and removed all exceptions. I'm unsure about the cause of this and a little worried that my machine has become host to some form of malware.

    I'm looking for suggestions on how to trouble shoot this problem. Is there a way, for example, to see is something has placed hooks into the even that causes this dialog to display itself?
  2. iVoid macrumors 65816

    Jan 9, 2007
    Yeah, I THINK I might be seeing the same thing on my MAcPro with Snow Leopard.

    I say THINK, since it flashes so fast, I'm not 100% sure it's the firewall message. I've tried capturing it with screen recording, but haven't yet caught it (might be the low framerate missing it).

    I've been getting it mostly in Firefox (which is currently set to deny incoming connections), but have seen it flash a few times in other apps too.

    Is it possible that the system puts the message up and then checks to see if there's a setting to allow/disallow connections already and then clears the message?
  3. kinabrew macrumors newbie

    Nov 15, 2007
    I am seeing the same behavior. I only rarely visit MacRumors forums, but I found this topic through a Google search for snow leopard firewall disappears.
  4. Vicegrip thread starter macrumors newbie

    Jul 15, 2008
    I essentially decided to uninstall apps I suspected used the network but might not be snow leopard compatible. Peer Guardian comes to mind.

    I also reinstalled iTunes (uninstall then reinstall that is) based on a thread I read on the Apple support site.

    The connections window seemed to behave properly when I last saw it.

    I'll update here if I see this problem again.
  5. Unnamed1 macrumors member

    Oct 4, 2005
    I get this too. It always pops up and disappears when I start Adium. Do you have the allow trusted box ticked under security/firewall?

    I figured it was just a bug that hasn't been fixed properly... is very annoying though.
  6. Vicegrip thread starter macrumors newbie

    Jul 15, 2008
    I turned off the auto-allow signed apps.

    This has for consequence of forcing me to allow apps like kerberos, smbd, nmbd etc... and a few others, but I refuse to give a blank check to any app just because it is signed. It also has the extra benefit of allowing you to see the dialog more often.

    There is a thread on the apple forums regarding iTunes causing this behaviour when it is running. That's why I reinstalled it. As long as you don't let it re-create your music, your current library should stay fine during a reinstall.

    What I did notice is that the problem is due to something loading. On first boot, the kerberos "allow collections" window would appear and would allow me to click it. It was only after something else loaded that the problem would start.

    This is why I started removing anything I thought might have hooks in the network layer.

    For now it seems to be working, but I haven't run anything new that required to listen for connections either.
  7. Vicegrip thread starter macrumors newbie

    Jul 15, 2008
    Still happening

    Unfortunately this problem is still occurring. It had briefly appeared to stop, but now once again, while trying to connect to a network drive, the dialog pops-up and disappears and all of my connection attempts then time-out.

    This is an annoying problem.
  8. inkhorn macrumors member


    Oct 8, 2009
    I'm also getting the same disappearing dialog asking whether to allow incoming connections to an application.

    In this case it's Vuze, and the lack of being able to grant incoming connections makes the whole app unusable.

    I've tried tinkering with the 'allow signed apps automatic access' toggle to no avail. The only thing I can do to get it to work as it's intended is to reboot and then the incoming connections dialog window stays open long enough for me to choose an option.

    Hope this gets fixed soon!
  9. chaithrika macrumors newbie

    Nov 24, 2008
    Firewall dialog flashes and disappears in Snow Leopard

    I have been facing same problem with my app which does a device discovery. When Firewall is turned on, first response to the discovery brings up the firewall dialog.
    On getting further responses to discovery the dialog just disappears.
    Since I have been receiving the discovery responses in a 'for' loop, the firewall dialog just used to flash not allowing me to click any of the buttons there.

    But I learned that if I got my application code signed (not with self signed certificate), it works fine though it does not bring up the firewall dialog.

Share This Page