Firewall blocking Airport and Airtunes

Discussion in 'Mac Accessories' started by justonwo, Jul 22, 2010.

  1. justonwo macrumors newbie

    Joined:
    Apr 30, 2010
    Location:
    SF Bay Area
    #1
    I have AVG Firewall and I can't seem to figure out how to allow Airtunes and Airport Utility to get through. When I open Airport Utility, I can't find my Extreme or Express stations. When I open iTunes, I don't see an option for Airtunes. If I turn off the firewall, all is well.

    Does anyone have any idea how to fix this?
     
  2. rainingwaffles macrumors newbie

    Joined:
    Dec 19, 2010
    #2
    This is the response I found through searches which worked for me...

    http://discussions.apple.com/thread.jspa?threadID=2118748

    """
    After having limited success myself, I've finally managed to get this to work and thought I'd share what I had to do. I'm using AVG version 9.0.709

    In Firewall Settings>Applications change the settings for itunes and Apple Bonjour for windows to "allow for all"

    Now go to system services>Manage user system rules

    Add 2 rules on for protocol: TCP
    direction: both ways
    local port: 3689
    remote port: all ports
    remote addresses: check the box for safe networks

    The second rule should be protocol: UDP
    local port: 5353
    remote port: all ports
    remote address: check box for safe networks.

    By not checking "all networks" and instead checking "safe networks" this excludes the internet (unless you've defined it as safe, which is definitely unwise), which minimises the risk of attack to your PC.
    """
     
  3. werf macrumors newbie

    Joined:
    Jan 29, 2011
    #3
    Thank you, rainingwaffles!

    This was VERY helpful info as this was my problem exactly. My only tidbit to add on is that i assume the direction for the second rule is also "both ways"? that's the option i chose, and so far everything is working perfectly! Now I (kinda) know how to do this, I may even eventually try (again) to see if i can get airport express to allow me to print remotely too! Merci beaucoup!
     

Share This Page