Firewall is hiding...

Discussion in 'Mac Basics and Help' started by acearchie, Sep 3, 2007.

  1. acearchie macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #1
    I recently went to the sharing icon in System preferances and clicked on Firewall,

    It came up with a screen saying that there was another Firewall active and until I had disabled that one I could not use the Apple Firewall...

    I had no knowledge that I had one running, I have probably installed on at one time but I normally delete things when I dont use them using clean app...

    Can anyone think of a solution to this problem?

    Thanks
     
  2. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #2
    I wish Apple would fix this graphically.

    Open the Terminal application.

    Type ipfw flush and press <return> or <enter> key.
     
  3. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #3
    Damn, It seemed as though it was going to work! Then this happened!

    Dont know what the solution will be!

    EDIT: sorry dont know if it makes any difference but sytem preferences was not open when I tried the command!
     

    Attached Files:

  4. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
  5. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #5
    ok, kinda missed that one!

    EDIT: after a small search I've found its a shell command, anywho Im pretty basic with terminal and would need some help with this! Thanks though!
     
  6. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #6

    I'm just making a guess.
     
  7. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #7
    Looked great! I got this lovely screen
    [​IMG]

    But to no avail! I still get this irritating screen!
    [​IMG]

    I reckon I/we are getting closer to the solution though!

    Thanks
     
  8. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #8
    So, I still have this problem alot later and would quite like a solution! Ha

    Anyone have any suggestions?

    Thanks
     
  9. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #9
    Code:
    sudo ipfw l
    
    (that's a lowercase L)

    This will list if ipfw2 is actually doing any port blocking. Default is:

    Code:
    65535 allow ip from any to any
    If that is what you see, then it's something else.
     
  10. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #10
    Ok i did that but I got what you had quoted?
    (see picture)

    But im confused, what does OSX think is acting as a firewall if all the ports are open?

    Anyone shed any light on this?

    And thank you to Yellow for getting me one step closer to the end of this conundrum!

    Thanks
     

    Attached Files:

  11. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #11
    ipfw is ALWAYS running. The default is what you see above, all ports open.
    My guess is that the GUIfied control for ipfw is either out to lunch, or it thinks another firewall is running.

    You can try to nuke:

    /Library/Preferences/com.apple.sharing.firewall.plist

    Restart

    And check again if you can start the firewall up. If not..
     
  12. WildPalms macrumors 6502a

    WildPalms

    Joined:
    Jan 4, 2006
    Location:
    Honolulu, HI
    #12
    ....and if its still a problem, bootup with no extensions running (hold shift during startup sequence). If you can then access firewall settings via Sys. Prefs, you might find a leftover in /System/Library/Extensions or in your Startup that is setting up a rule that is starting under normal boot.
     
  13. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #13
    And if i just dont have one???
     

    Attached Files:

  14. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #14
    Hmm.. are you running Tiger? Doesn't look like it..
     
  15. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #15
    :-O
     

    Attached Files:

  16. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #16
  17. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #17
    Already covered:

     
  18. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #18
    still pretty much way over my head...

    Do you want me to still do the "sudo ipfw list"

    or is that what I did before! My next step will be to try rebooting as you stated!
     
  19. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #19
    sudo ipfw l = sudo ipfw list

    The question now is have you installed any sort of third party firewalls, or firewall log controller that might ahve taken ownership of firewall duties?
     
  20. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #20
    Possibly little snitch but Ive disabled that and I still have the same problem.

    I dont know if this helps but I tried to share my iTunes to my mums laptop and it would not share something about port 3XXX not being open.

    So I did my old "sudo ipfw flush"

    and it then started working! But then after I disconnect it does it again!

    Thanks
     
  21. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #21
    nah, Little Snitch wouldn't do it.

    So.. restart. Then when you login, give us the results of:

    sudo ipfw list
     
  22. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #22
    OK will do, currently caught me burning a DVD so it will be a bit but after that I will post straight away!
     
  23. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #23
    OK so i did that and got some rather odd results (see picture) I dont know if any of these are personal to me (as in I should blur them) so I have posted it completely uncensored, also I then successfully "sudo ipfw fulsh"-ed and now the sharing iTunes is working again!

    Thanks again!
     

    Attached Files:

  24. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #24
    Yeah, since you got that at startup.. something else is controlling ipfw.

    You'll have to empower yourself to find out what it is.. perhaps something in /Library/StartupItems/ will lead you to the cause.
     
  25. acearchie thread starter macrumors 68040

    acearchie

    Joined:
    Jan 15, 2006
    #25
    :-O

    Okay couldnt have spelt it out more simply!!!

    Do you think getting rid of this will solve this long running problem?
     

    Attached Files:

Share This Page