Firewall issue- ipfw -f flush (Apple Remote)

Discussion in 'macOS' started by farmerku, Aug 6, 2011.

  1. farmerku macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #1
    When I first got my iPhone I wasn't get the Apple Remote to access the iTunes on my Mac.

    After months of research I found that by entering this command into terminal...

    sudo /sbin/ipfw -f flush

    ...my iPhone was able to access the library without issue. The problem I have is that when I restart my Mac I have to re-enter this command for the remote to work.

    Does anyone know what the issue is here? Is there a way to fix this permanently?

    Just to clarify this issue occurred in both Snow Leopard and Lion.

    Thanks for the help in advance.
     
  2. farmerku thread starter macrumors regular

    farmerku

    Joined:
    May 10, 2008
    #2
    I have done a few tests and found that after a restart port 3689 is denied... does anyone know how to manually open this permanently?
     
  3. Alrescha, Aug 7, 2011
    Last edited: Aug 12, 2011

    Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    ipfw flush means 'delete all firewall rules'.

    If you want this to be the default, turn off the firewall. Otherwise, make sure iTunes is allowed incoming connections in the firewall configuration.

    Another possibility is that you (or a program you ran) modified the default IPFW firewall configuration. Check in /Library/StartupItems/Firewall (it's not there by default), or perhaps /Library/LaunchDaemons/net.waterroof.rules.plist if you've played with WaterRoof.
    A.
     

Share This Page