Firewall keeps asking for permission

Discussion in 'Mac Basics and Help' started by marcin0903, Jul 6, 2010.

  1. marcin0903 macrumors regular

    Joined:
    May 9, 2009
    #1
    Hi, I have a problem with my firewall on OS X 10.6.4 - it is asking for permission in few apps (iTunes, Dropbox, Air Video Server), when I asks over and over, of course I added it to the list in the System Preferencys in Security, but still asks, every time I start each app - do you know how to solve my problem :)?
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Create a test user account and see if the issue still occurs there. Report back.
     
  3. marcin0903 thread starter macrumors regular

    Joined:
    May 9, 2009
    #3
    On test user account, firewall still asks for Air Video Server, Dropbox, but not for iTunes.. strange..
    Do you have any tips?
     
  4. Sir Lorad macrumors member

    Joined:
    Apr 22, 2010
    Location:
    Brazil
    #4
    In my macbook firewall also asks for permition everytime I open iTunes.

    Have no idea to solve.
     
  5. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #5
    Since it still does ask for permission in the test account, I'd recommend doing a Archive and Install of the system because it is a system-wide issue.


    Uninstall iTunes completely and reinstall it.
     
  6. munkery macrumors 68020

    munkery

    Joined:
    Dec 18, 2006
    #6
    Have you tried using Disk Utility to "Repair Disk Permissions" for Macintosh HD (or whatever you renamed your HD).
     
  7. marcin0903 thread starter macrumors regular

    Joined:
    May 9, 2009
    #7
    Right now doing it - if it helps or not I will let you know :)
     
  8. John Jacob macrumors 6502a

    John Jacob

    Joined:
    Feb 11, 2003
    Location:
    Columbia, MD
    #8
    I have the same problem in Leopard (10.5.8). Firewall keeps asking me each time I open Microsoft applications (Word, Excel, Powerpoint) even though I have set to deny in system preferences.

    Worse, the firewall keeps asking me each time I start or receive a voice or video chat with the Google Video Chat plugin, although I have set it to allow in system preferences. This means that someone initiates a voice chat with me, I accept the chat, and neither of us can hear anything until Mac OS X pops up the window, usually ten seconds later.
     
  9. marcin0903 thread starter macrumors regular

    Joined:
    May 9, 2009
    #9
    OK, seems that I have a solution:


    I tried that with Dropbox and Air Video Server and it works, now I am gonna to do that with iTunes, but if I delete iTunes (in fact reinstall it), will I have to sync my devices again (first it will remove whole content from my iPad/iPhone/iPod, than it will sync library again) or maybe the sync data is stored somewhere else and if I delete iTunes.app I won't have to resync my devices?

    EDIT: Just removed iTunes.app and downloaded package with new iTunes from Apple.com, installed (as described above) and now firewall doesn't ask me everytime :) - and also all content from iTunes (sync data, libraries) stayed intact! :)
     
  10. Boldy6 macrumors newbie

    Joined:
    Aug 3, 2010
    #10
    Apple Support got me to disable remote app tick box

    Hi,

    i activated the firewall yesterday and every time i opened itunes it wanted me to allow itunes.app etc like u guys
    tech support guy been working on it 2 days and says traced to
    itunes/system preferences/devices and had to untick box "look for ipod, iphone ipad remotes" and click on forget remotes
    tried itunes no problem, then ticked it again and click ok and no further problem until activate remote app again by passcode etc

    so if you dont want it to keep asking you to allow access u need to forget remotes

    so i assume this only affects people who use apple remote app ?

    maybe thats why reinstalling itunes worked till remote library is used again i reckon
    been escalated to engineers i believe
     
  11. Sir Lorad macrumors member

    Joined:
    Apr 22, 2010
    Location:
    Brazil
    #11
    Bold6,

    Will try that tonight.
    Hope it works. Would be great!
     
  12. Sir Lorad macrumors member

    Joined:
    Apr 22, 2010
    Location:
    Brazil
    #12
    The solution proposed made no difference.

    keeps asking permission.

    :(
     

Share This Page