Firewire 800 Port Not Working

Discussion in 'iMac' started by Tech-Minded, Jul 25, 2010.

  1. Tech-Minded macrumors regular

    Jan 30, 2010
    I have a late 2007 iMac 20inch and suddenly the firewire 800 just stopped working. I've tried putting different F800 devices in the same port and none work. They work on other computers. I've tried resetting everything; PRAM, the computer, and deleting the cache. Anyone else experience this? I noticed that this began to happen after I turned off my external hard drive without ejecting it.
  2. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    Go to About this Mac and then More Info. Click on FireWire and post what it says.
  3. spinnerlys Guest


    Sep 7, 2008
    forlod bygningen
    The following helped with the late 2007 iMac (aluminium):

    [URL="";]Intel-based Macs: Resetting the System Management Controller (SMC)[/URL]
  4. Tech-Minded thread starter macrumors regular

    Jan 30, 2010
    Thanks, resetting the SMC did it. Finally getting worthy F800 speeds again.

Share This Page