Firewire 800 stability

Discussion in 'Mac Accessories' started by Sic, Apr 8, 2009.

  1. Sic macrumors 6502

    Joined:
    Oct 26, 2005
    Location:
    Southampton UK
    #1
    I've got a WD MyPassport Studio drive, and the Firewire is incredibly unstable on it. USB is fine, but quite frequently, the drive just stops responding and I have to unplug it and plug it back in really quickly to make it respond again. I contacted Western Digital who basically said it was not a problem as far as they're concerned, and I can't replicate it. The console gives me nothing other than that the drive has gone (which only happens when I unplug it). Does anyone have any ideas?

    I've noticed that the FW800-style connectors seem to be particularly poor quality and slide into/out of their corresponding ports a little too easily. Is there such thing as a metal-ported FW800 cable that I could try? Or just a better quality cable? It's not essential, as USB is plenty fast enough, but I don't like having something that doesn't work as it should - it makes me nervous of how it's next going to annoy me!
     
  2. Tosser macrumors 68030

    Joined:
    Jan 15, 2008
    #2
    It's propably the inferior Agere chipset acting up, and not a loose connector.
     
  3. Sic thread starter macrumors 6502

    Joined:
    Oct 26, 2005
    Location:
    Southampton UK
    #3
    I was hoping someone wouldn't say that. Is there anything I can do? I've only had the drive since Christmas.
     
  4. Tosser macrumors 68030

    Joined:
    Jan 15, 2008
    #4
    You can try a different cable, and then try a different fw800 drive. But it sounds more like what we experience with FW audio interfaces if we use the new macs. The FW port is utterly useless: Drop outs and sometimes not even recognising anything is plugged in.
     
  5. Sic thread starter macrumors 6502

    Joined:
    Oct 26, 2005
    Location:
    Southampton UK
    #5
    I'll pick up another cable, but this is my only FW800 drive. Didn't realise that the FW ports on new Macs were synonymously awful. You'd think that they'd make some effort, what with it being their own little venture and all. Thanks for the info :)
     
  6. Tosser macrumors 68030

    Joined:
    Jan 15, 2008
    #6
    No problem. I hope it's just the cable. :)

    Btw, there's a huge thread on the removal of firewire around here. In that thread the Agere chipset is talked about a lot (and not just by me). The firewire issue was the last straw for me. Got meself a nice Thinkpad on the way (well, when DHL decides they want to deliver as they were paid to do).
     
  7. Sic thread starter macrumors 6502

    Joined:
    Oct 26, 2005
    Location:
    Southampton UK
    #7
    I only just got this new laptop and I love it except for this FireWire issue (which I suppose I can grudgingly live with!) To be honest, I don't think I could go back to Windows now. Every time I use it, it just drives me mental!

    Cheers again. Enjoy your new laptop!
     
  8. Tosser macrumors 68030

    Joined:
    Jan 15, 2008

Share This Page