FireWire intermittent problem with iMac

Discussion in 'iMac' started by g-boac, Dec 17, 2011.

  1. g-boac, Dec 17, 2011
    Last edited: Dec 17, 2011

    g-boac macrumors 6502

    Oct 7, 2007
    Having a problem with my mid-2011 iMac FireWire port: connecting it to external FireWire drives leads to intermittent dropouts when copying files to or from the external drive. Short, small files copy over fine. If I attempt to copy over large directories, generally within 5-10 minutes, the drive will begin to audibly click, the LED on the drive will flicker, and the Finder window will quit, giving an error message. The problem occurs on multiple FireWire drives, and in every case, each FireWire drive works fine when plugged into my 2010 MacBook Pro.

    Finally, setting my MacBook Pro to Target Disk mode, and connecting it to my iMac via FireWire works just fine, so that implies that data carries across the FireWire port just fine.

    I've tried a web search; also tried resetting PRAM and SMC and results remain the same. Anyone had any similar experiences, or can anybody offer any troubleshooting ideas? Thanks!!

  2. alksion macrumors 68000


    Sep 10, 2010
    Los Angeles County
    Can't say I have had the same experience, but I am going to say it first, because many of the people who viewed this were probably thinking it as well.

    Unless someone else who has had this exact problem comes up with a fix, I say take it to Apple.

    I understand that it may no be convenient for you, but at the same time it seems like you really narrowed down your problem and to me, it does sound like a possible hardware problem.
  3. g-boac thread starter macrumors 6502

    Oct 7, 2007
    I was inclined to think that - but wanted to be sure there weren't obvious or known fixes I was overlooking before going through the real hassle of getting an iMac to an Apple store. In addition to being without the hardware for a few days. Thanks!


Share This Page