FireWire isn't working

Discussion in 'PowerPC Macs' started by josbell2515, Jan 8, 2015.

  1. josbell2515 macrumors newbie

    Joined:
    Oct 21, 2010
    #1
    Hi all,
    A couple of weeks ago I got a new iBook and I wanted to get some of the data off of my old one. I turned on the other one and the hard drive for that one never showed up on my new one's desktop. :confused: Also, the old one's screen isn't working, but I've been able to get that one's hard drive to show up on another Mac's desktop.
    How can I fix this? This is kinda confusing...
     
  2. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #2
    You need to hold T on the busted Mac at boot.
     
  3. josbell2515 thread starter macrumors newbie

    Joined:
    Oct 21, 2010
    #3
    Oh yeah, I forgot that when I was describing the issue.
    Holding down "T" when starting the broken one doesn't do anything...
     
  4. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #4
    It should show a target disk mode screen but because the screen is broken you don't know if it works. Hold it for long enough, like 10 seconds to be sure. If that doesn't work then plug in an external monitor (assuming the display is bad and not the gpu).
     
  5. josbell2515 thread starter macrumors newbie

    Joined:
    Oct 21, 2010
    #5
    About that...

    I'll try to see if holding down T longer works. After the screen broke on that one I tried hooking it up to an external monitor and nothing showed up, so I guess it might be the GPU... :confused:
    There has to be a way around this, as I've tried putting the computer into Target Disk Mode without a display and it worked.
     
  6. josbell2515 thread starter macrumors newbie

    Joined:
    Oct 21, 2010
    #6
    I think I might know what happened

    So I did some research and it turns out that the old Mac isn't the problem - it's the current one that I have. System Profiler says that it can't find any FireWire devices, even when there's nothing in there, possibly meaning that it's failed. :(
    Is there a way that I can fix this? Better yet, is there another way that I can get my data off of the old computer?
     
  7. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #7
    That is really weird. The FireWire is integrated onto the logic board. If it does not work then that is weird.

    To get your data off, take the hard drive out and put it in an enclosure. Either this or connect your machine to an external monitor and transfer the data through ethernet or wifi or usb stick or disk.
     
  8. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #8
    I'm just gonna go back to basic troubleshooting here. Are you positive your keyboard is good? Have you tried target disk booting using an external USB keyboard instead of the built in one?
     
  9. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #9
    It is possible for System Profiler not to report an internal hardware device if the relevant support in the installed OS is missing. I had this with a TiBook and OS9 because the version of OS9 installed was not the right one for the the TiBook. I would assume with OS X it is less likely. Running your AHT disc or using the show-devs command via Open Firmware would confirm whether or not your internal device has croaked.
     

Share This Page