FireWire Problem

Discussion in 'iMac' started by armani, Aug 12, 2007.

  1. armani macrumors regular

    Joined:
    Jul 20, 2007
    #1
    Hi, I have iMac 24" which I bought five days ago. I have external hard drive which I wanted to hook up to the mac. Turned it on, the mac did not recognize it, nothing happened. I know this drive works. I tried USB - did work. I tried to hook up the camera - did not respond at all. I noticed on apple site forum that other people have the same problem, firewire does not respond. And as I understand tech support at apple know nothing how to fix it. So here we go, the consequences of buying the product which just came out. I would hate to take it back to the store and hope it is just a driver issue or something which can be fixed via updates. I would also add that games under boot camp don't work at all, just dropping out to desktop.
     
  2. CBAviator macrumors 6502

    Joined:
    Jun 10, 2007
    Location:
    Nederland
    #2
    Did you check for a firmware update from your hard drive's producer? It's possibly the firmware isn't installed in the iMac, hence why it doesn't recognize it. It's been known to happen from time to time!
     
  3. armani thread starter macrumors regular

    Joined:
    Jul 20, 2007
    #3
    I went to the apple store today and they connected their firewire HD and it worked just fine. So I returned mine. I am glad the port works.
     
  4. Royale w/cheese macrumors 6502a

    Joined:
    Jun 5, 2007
  5. armani thread starter macrumors regular

    Joined:
    Jul 20, 2007
    #5
    No, I tried three cables I have at home. I think it is an HD firmware. WD needs to update it.
     
  6. Royale w/cheese macrumors 6502a

    Joined:
    Jun 5, 2007
    #6
    What about the camera, did you get that to work?
     
  7. armani thread starter macrumors regular

    Joined:
    Jul 20, 2007
    #7
    yes, it is working now
     
  8. Subculture macrumors newbie

    Joined:
    Aug 15, 2007
    #8
    I JUST had the same problem. WD MyBook. Worked fine on my Mac mini, but it just refused to work with the new 20" iMac.

    Bleh!

    Using it via USB now... not ideal, but I need my info.
     
  9. armani thread starter macrumors regular

    Joined:
    Jul 20, 2007
    #9
    It is clear now it is WD problem. When I spoke to them they knew nothing what to do and suggested three things: reformat the drive under boot camp or on windows computer; wait for firmware update; to return it. I did return it. Why wait, I will just buy it later, it is getting cheaper anyways.
     

Share This Page