Firewire Target Computer Won't Show Up on Host

Discussion in 'macOS' started by spellflower, Feb 25, 2012.

  1. spellflower macrumors regular

    Joined:
    Jun 7, 2005
    #1
    I'm trying to access my broken MacBook's hard drive to save some files by using FireWire Target Disc Mode as described here:
    http://support.apple.com/kb/HT1661

    My MacBook will not boot up normally, but it does boot to FireWire mode. If I push the power button and hold down the "T" key, it displays a FireWire logo that moves around the screen.

    But when I connect it with a FireWire cable to my girlfriend's MacBook, it doesn't show up on her desktop.

    Is there anything else I can try? Or is my MacBook just too broken to save these files?






    Background Info:

    My MacBook crashed- literally- onto the floor.

    I picked it up and opened it and it made a lot of bad sounding mechanical noises.

    I was able to drag windows around and minimize them, but it was very sluggish. When I clicked on an image on the desktop it opened up, but only after several minutes.

    I restarted, but it just showed a :apple: logo and a spinning wheel for an hour.

    I took it to the Genius Bar, and they said I should try using FireWire Target Mode to save files and then do a full erase of the hard drive, and reinstall everything. I have a Time Machine backup, but it's not recent, and I'd like to save pictures that aren't on it.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Does it show up in Disk Utility?


    ____________________________________________________________

    Links to guides on how to use Disk Utility, the application Mac OS X provides for managing internal and external HDD/SSDs and its formats.
    ____________________________________________________________
     
  3. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #3
    Good idea, simsaladimbaba!

    It does indeed show up in Disk Utility.

    But it still doesn't show on the desktop or under "devices" on the left side of Finder windows.

    So how can I access the files?






    One more thought....
    Could I possibly repair my hard drive by using Disk Utility on my girlfriend's MacBook?
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    Is it mounted or not mounted? If it is the latter, select it and click the MOUNT button.
    [​IMG]
    If it is mounted, go to Finder > Preferences > Sidebar > External disks and check it.

    Yes.
     
  5. Elbert C macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #5
    What OSX versions are installed in both your and girlfriend's Macs?
    For some reason my OSX 10.6.8 MBP in TDM didn't show up on my 10.4.11 PBG4s Desktop or Finder window the last time I tried it. In Disk Utility it showed the 250.6. GB FUJITSU hdd icon but the Macintosh HD icon showed up as an empty paper icon instead of the hdd icon.
     
  6. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #6
    Okay, the disk was not mounted, so I tried to mount it.

    A box popped up and said it couldn't be mounted and that I should try running First Aid on the disk. I did, and got this:
    [​IMG]

    I'm pretty sure my MacBook has (had) the last version of Leopard. I had done all the updates, but never installed Snow Leopard.

    My girlfriend's computer is running 10.5.8.

    Is there any hope of recovering pictures from my MacBook HD?

    Or should I give up on that and just go ahead and do a full erase and reinstall OSX.

    Thanks again for the help!
     
  7. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #7
    This is the log from Disk Utility:

    **********
    2012-02-25 18:37:29 -0500: Disk Utility started.

    2012-02-25 18:49:50 -0500: Eject of “AAPL FireWire Target Media” failed
    2012-02-25 23:07:19 -0500: Mount of “Macintosh HD” failed
    2012-02-25 23:07:43 -0500: Verify and Repair volume “Macintosh HD”
    Starting repair tool: 2012-02-25 23:07:43 -0500
    2012-02-25 23:07:48 -0500: Checking Journaled HFS Plus volume.
    2012-02-25 23:07:59 -0500: Checking Extents Overflow file.
    2012-02-25 23:07:59 -0500: Checking Catalog file.
    2012-02-25 23:17:19 -0500: Invalid sibling link
    2012-02-25 23:17:19 -0500: Rebuilding Catalog B-tree.
    2012-02-25 23:25:20 -0500: 2012-02-25 23:25:20 -0500: The volume Macintosh HD could not be repaired.

    2012-02-25 23:34:22 -0500: Error: Filesystem verify or repair failed.2012-02-25 23:34:22 -0500:
    2012-02-25 23:34:22 -0500: Disk Utility stopped repairing “(null)” because the following error was encountered:

    Filesystem verify or repair failed.
    2012-02-25 23:34:22 -0500: [DUDiskController mountDisk] expecting DUDisk, but got nil
    2012-02-25 23:34:22 -0500:

    2012-02-25 23:35:22 -0500: Mount of “Macintosh HD” failed
    2012-02-25 23:39:08 -0500: Mount of “Macintosh HD” failed
    2012-02-25 23:46:52 -0500: Verify and Repair volume “Macintosh HD”
    Starting repair tool: 2012-02-25 23:46:52 -0500
     
  8. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #8
    It's not looking good...That disk must have suffered serious, irreparable damage in the fall. There are third part apps that can sometimes recover data, but if the drive is that far gone, the only way you are likely to get data back is to pay $$$ to a specialist company.

    Disk Warrior is a name that springs to mind here, should turn up on Google. Good luck!

    ----------

    It's up to you if you want to buy it....:

    http://www.alsoft.com/diskwarrior/
     
  9. spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #9
    Thanks.

    I guess I'll get up tomorrow and begin reinstalling everything on the off chance that that will work.

    If not, it's off to New Egg to buy a new HD. :(
     
  10. spellflower, Feb 26, 2012
    Last edited: Feb 26, 2012

    spellflower thread starter macrumors regular

    Joined:
    Jun 7, 2005
    #10
    Anyone have any brilliant last ditch ideas before I wipe the drive?

    The pics aren't worth paying lots of money for, but I will miss them.
     
  11. Elbert C macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #11
    DiskWarrior
     
  12. Lisafloss macrumors newbie

    Joined:
    Apr 21, 2013
    #12
    Similar problem

    Hello, i am trying to drad files from my old compiputer to new one with the old 'target' one to the new 'host one.
    My old mac was g5 power pc osx10.5 and newer one late 2009 21.5" screen intel imac running osx10.6.8.

    My old one had been having immediately recurring kernel panics but I have been able to start it up as target disk, floating firewire symbol appears on its screen. I have joined it to my new mac using a 400 800 firewire cable I bought from amazon.
    The yellow hard drive from old computer sppears on my new mac's desktop but when i click and open it, all i find in there are the files on my new mac and nothing from old one.

    What is happening or what am indoing wrong?!

    Many thanks for any help you give me. I'm not overly technical but can understand the basics.

    L
     
  13. Elbert C macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #13
    Have you tried using Migration Assistant to transfer the files?
     

Share This Page