Firewire target disk mode not seeing all disks/partitions

Discussion in 'Mac Pro' started by spiritlevel, Feb 11, 2008.

  1. spiritlevel macrumors 6502

    Joined:
    Nov 5, 2007
    #1
    My new Mac Pro 2.8 Octo arrived today :)

    However, I immediately ran into a problem when I tried to migrate data from my old G4 Mirror door using firewire target mode. The G4 has 3 disks in it split into 6 partitions - a 250GB with 3 partitions (which includes the startup drive) a 120GB with 2 partitions, and an unpartitioned 120GB.

    Only the unpartitioned 120GB drive shows up in firewire target mode - and as this is not the startup drive it means I can't migrate all my settings etc. (When I start up the G4 in normal mode all disks are available again)

    Can anyone suggest why this might be happening? or have any ideas as to how I can migrate my old data?

    thanks.
     
  2. mrcandy macrumors regular

    Joined:
    Nov 12, 2007
    Location:
    Calgary, AB Canada
    #2
    I'm assuming these are all IDE (PATA)....

    Remove all drives from the G4 except the drive with the boot partition. Make sure that the boot drive is set as master (not CS or slave). Restart in target mode and you should see the boot drive.

    Target mode will only 'see' one drive, if you need data from the other drive you will have to move it later. You can still do so via firewire by ensuring the second drive is connected as the master drive and re-starting in target mode.
     
  3. spiritlevel thread starter macrumors 6502

    Joined:
    Nov 5, 2007
    #3
    Thanks MrCandy

    Spot on advice which solved my migration issues - until I got to the 3rd drive which seems to have died in the changeover - but thats another story...
     

Share This Page