FireWire Target Mode Issue

Discussion in 'Mac Basics and Help' started by blu772, Jun 6, 2008.

  1. blu772 macrumors newbie

    Joined:
    Jun 6, 2008
    #1
    I have a G4 trapped in firewire target mode and now also cannot see disc as harddrive on linked G4.
    I am unable to start from cd (keyboard C on startup) to fresh install old system either. Also now is unable to be seen from other G4 when linked.
    So now it just starts up with flashing firewire logo, and is unable to be seen by linked other mac. Is it lost for good?


    I connected two G4s via firewire cable to install an OS from one to the other.
    The install process had problem, so half installed. Could not start the target mac from cd to reinstall old system. Tried to wipe disc from linked mac but could not fully do so, now the disc wont show up as mounted hard drive.

    I dont know what else i can do to rescue the drive as it appears to be trapped in sorry state!!:confused:

    From reading a few articles, there seems to be no mention of how to get 'out' of firewire target mode so am i right in assuming that it should do so automatically on restart? Also note, holding 't' did not work to get into target mode, i had to go to startup preference and choose target mode restart from there initially.
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    I would try resetting the PRAM as it stores the default boot state. cmd+opt+p+r on boot

    Hopefully it will kick it out of the firewire mode and thus enable you to boot from the CD.
     
  3. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #3
    Ok, don't panic.

    Assume this:

    G4 your are trying to reinstall the OS is Mac1
    G4 you are using to do the reinstall from is Mac2

    1. Power off Mac1

    2. Power on Mac 1 in Target mode and make sure firewire cable is connected securely to both Macs. Reinsert cable into both ports if needed.

    3. Reboot Mac2

    4. Don't worry if you dont see the hard drive from Mac1 on your desktop.

    5. Launch Disk Utility

    6. On the left, see if you can see the drive (actual device, not a volume beneath it) from Mac1. If so proceed. If not, the drive from Mac1 is totally hosed.

    7. Select the drive from Mac1. Click the Partitions tab. Change "Current" to "1 Partition" (this enables the option button).

    8. Click the options button. Make sure "Apple Partition" map is checked. Click OK.

    9. Name the disk and click "Apply". This will totally reformat Mac1's drive.

    10. Quit Disk Utility

    11. Insert the installer DVD in Mac2 and open a window to it.

    12. Run the installer and select the drive from Mac1.

    If you still have problems, report back.
     
  4. blu772 thread starter macrumors newbie

    Joined:
    Jun 6, 2008
    #4
    Tried the PRAM no joy,
    And rebooted, checked disc utility and still no show of the harddrive, so looks hosed!

    Its not too big a deal if wrecked as its only a small drive and i have another i could replace it with if absolutely necessary, although Ill be more apprehensive about using targetmode this way again, as it would be the first time ive witnessed an irreversable situation, always been a way out before.. ie, should promt that a connected disc requires formatting.

    Which gives me idea, maybe if i place the wrecked drive in the other mac it may prompt to format it??!! as it wont to starting from that drive, so no firewire mode issue..
     
  5. blu772 thread starter macrumors newbie

    Joined:
    Jun 6, 2008
    #5
    Well I thought I was going to be posting success,
    I placed wrecked drive in other computer, as predicted said not recognised and gave the option to initialize. So wiped it, while there, installed old system, and all is fine with the drive, started up system fine.

    Just placed it back into original computer, and it boots up with same Firewire logo!!!
    It seems this firewire target mode is something outside the realms of the standard operating system. Anyone know what this target mode is doing and how to cancel it?

    ps. Its doing this while not even being connected by firewire cable.

    pps. The keyboard does not function in openfirmware mode before anyone suggests..

    This is frustrating me now if this target mode has now destroyed a full G4 machine from ever functioning.
     
  6. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #6
    Thats correct it runs out of your firmware. So you need to get the pram reset. I would try unplugging the G4, taking the battery out of it waiting a minute or so and putting it back in and booting up.
     
  7. blu772 thread starter macrumors newbie

    Joined:
    Jun 6, 2008
    #7
    Thanks guys, success!
    After removing the battery a few times and zapping the PRAM, it bypassed the target mode into the system.
    TBH I think what slowed down the process was power issues with my usb ports, ie keyboard not functioning properly. After doing the same thing but switching usb ports it eventually worked.
    So I suppose basically zap the PRAM and issue solved,
    Thanks again.
     

Share This Page