Firewire won't mount external HD on laptop

Discussion in 'Mac Accessories' started by spookyspook, Aug 29, 2006.

  1. spookyspook macrumors newbie

    Aug 29, 2006

    I recently tried to mount a Seagate external HD via Firewire on my PowerBook G4 laptop. HD does not appear in Disk Utility via Firewire 400. However it does appear via USB. I've tried with two different HD's - same results. I've returned the HDs, but I'm wondering: think it's a problem with my Firewire? Anyone else have a problem with laptop Firewire? This is the first time I've tried using the Firewire port.

    The weird thing is that the "powering up" sound on the external HD gets played through my computer speaker set-up when the HD is connected via Firewire. So obviously there is a connection of some kind occuring.

    Any ideas? I'm considering trying an external HD by OWC. Maybe that will make a difference?
  2. blodwyn macrumors 65816

    Jul 28, 2004
    Portland, Oregon
    How many FW connectors were on the back of the external HD? If there were 2 did you try both? One of my external HDs only works if I plug into one of the connectors, the other seems to be only for daisy chaining to other devices.

    The only real way to check your PB FW port is to try another device and see if it works

Share This Page