Firmware 2.2 and Mobileapplications framework

Discussion in 'Jailbreaks and iOS Hacks' started by Enigmafan420, Nov 25, 2008.

  1. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #1
    I have installed 2.2 (jailbroken). I can't get my special apps to work-they will not install.

    I have tried two methods to get them working:

    1) I copied the mobileapplications framework from my phone to my MAC using Cyberduck-then after the upgrade, I reinstalled it and changed permissions to 775.

    2) I used the moibleapplications framework patch available from Cydia.

    Neither of these worked.

    I rebooted by iphone after installing both times.

    Seems like I may have forgotten a step. Anyone else get this to work with 2.2?
     
  2. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #2
    you need to replace the mobileinstallation file with a patched mobileinstallation file within the mobileinstallation.framework folder. not mobileAPPLICATIONS. You can used the patched mobileinstallation from 2.1 on 2.2. Then change the permissions on the mobileinstallation file to 755, not 775

    You then need to download and install a legit application from the application store, a free app...before you can used any of the .ipa's
     
  3. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #3
    I have many purchased and free apps from the store. Do I need a NEW free app or can In install an existing app?
     
  4. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #4
    I blew out my phone, started basically from scratch when I upgraded iTunes and iPhone firmware.

    Once Pwned, I added the source: cydia.hackulo.us and installed miPatch.

    Didn't have to SSH into the phone, change permissions, etc. Everything (those apps) load up fine and work great. Maybe start from scratch again?
     
  5. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #5
    I am a SUCH A DORK :eek:

    I replaced the entire framework instead of just the file-When I restored just the file-all is well!

    Thanks to those offering input :)
     

Share This Page